Don't know if this is the correct place to post this but anyhow it is where I am.

I am building my first hexcopter.  I am using a radiolink AT10 transmitter and receiver.  the manual indicates that I need to link the receiver with the transmitter and outlines a very simple process to do this.  this include pushing the ID SET button.  Of coarse the ID SET button is not label in anyway.  There is a micro switch on the side of the receiver (R10D) that causes the LED to blink but never turns green.

I am using a Naza-m lite as a flight controller and when I hook up the controller to the management software the transmitter calibration works and all stick and switch movements are recognized.  When I disconnect the PC then the LED flashes yellow indication loss of transmitter signal.  I think this is related to a pairing issue although not sure why it would work connected to PC and not when disconnected.

I also have a apm 2.6 controller.  The reason I started with the Naza is the research I did prior to purchase indicated that would be quicker path to success.  maybe time to rethink this.

So long winded to get to my question.  Does anyone have experience (positive) with the radiolink ATO and how can I confirm it is paired.  I would like to eliminate that variable before switching controller as I don't want to stack up the unknowns



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Bryan:  Thanks again for replying

    I think it is in failsafe mode.  I have mapped a 3p switch to the failsafe mode and have tried it in all 3 positions same result.

    This is a screenshot of the management console.  So maybe a stupid question how to I get it out of failsafe mode.  Every screen I go to shows it as being off.  I should mention there is no GPS

    Sorry Screen shot does no load in forum box

    Thanks again


    • Ok, my bad you have to have the switches set up so it doesn't start in failsafe.

      Here is a good video on setup, he uses a JR radio but the radio doesn't matter just the configuration.

      You want to start the unit in M. If you don't have GPS you can use a 2p switch on the radio.

      If you want to set up failsafe here is a good video on assigning a 3pos switch and a second switch to go straight to failsafe.

      • AWESOME  that worked set the end points and started to work.

        Thanks so much for sticking with me really appreciate it


        • ps posted a picture with the motors running

          thanks again

          • No problem, I know how frustrated I got the first time. I'm actually going to be pulling my Naza off my Quad on monday to test out my APM before I start buying all the parts for a new Hex.

            Here;s to many hours of fun with your new rig!!

            • Maiden flight tonight no mishaps 

              Thanks again could not have done it without you


  • 1.  The Naza led is flashing Yellow.  The LED on the Receiver is solid red

    2. Nothing from the receiver.  the ESC ( I think) make a number of beeps and sound when the battery is first connected and the motors twitch

    3. Not really sure about his question.  The radio has multiple modes Airplane and Heli.  It is set to airplane mode.  It is in the default mode. ie: I just turn on the transmitter it beeps and the two leds flash for a couple second then go solid.  The manual indicates that this is normal.  One led for booting and one for transmitting.  The transmitting LED is solid Green.

    4.  When connected over USB to the Naza and management software.  it appears to work.  The calibration seemed to work all axis are centred and move when I move the corresponding control on the transmitter.  also the mode switch seems to work in selecting the failsafe mode.

    Everything seems to work when I am connected to the Computer over USB the Naza LED is green.  once I disconnect the computer the NAza flashed yellow.  also if I connect the battery while not connected to the computer it blinks green during boot then switch to flashing Yellow.

    Additionally when I try the motor start sequence on the transmitter nothing happens.  This is true no matter if I am connected or not to the computer.  I believe it is normal not to start the motors while connected to the computer because the USB cable is connects but that is just a guess

    Thanks for responding



    • re: #3

      The Naza has 4 flight modes:  GPS | FAILSAFE | A | FAILSAFE | M

      You need this mapped to a minimum of a 3 position switch. In Position 1  the indicator can be anywhere in the first failsafe area. In position 2 the indicator needs to be nearly dead center of 'A' and in position 3 it should be dead center of M. 

      If you are in failsafe mode you will get the yellow flashing as you have described. Now this yellow could be something other than flight mode calibration causing it but more often than not this one calibration is the issue. It's the only one that is difficult to get correct too. In normal practice you should be able to move from failsafe to A(attitude) or M(manual). If you are sure your settings are correct then remove the props from the motors(always best to be safe when troubleshooting) and power on your system with the TX in either A or M to see if you get a different error code.

      The yellow flashing are error codes so the speed and pattern are important. You should make note of them.  I think at one point I had an error 4-3-4(fast) and I don't remember what it was but took forever to figure it out.

  • 1. What exactly are you led flashes?

    2. Is there any audible report?

    3. What flight mode is the TX set to when you are pairing?

    4. Make sure your calibrations are as close to center as possible, my Naza-M v1 is very picky and if some are not dead center is jut has a hissy fit. (90% of the time this is the issue)

This reply was deleted.


sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24