I am working on a project where I use an arduino uno in the loop with a rc receiver feeding information into it, then the uno is sending information into an APM 2.5 autopilot to control a drone.

The first approach i was using involved code that used pulseIn to read the pwm from the receiver and it worked but was very sloppy.

So we switched over to interrupts and I used some example code to read the rc controller and the readings were beautiful.
http://rcarduino.blogspot.com/2012/01/how-to-read-rc-receiver-with.html

The next step was I wanted to read multiple channels and be able to control the drone again using my rc controller going through the uno. I found this project and it looked good I just needed to make some small tweaks for my application.
http://rcarduino.blogspot.com/2012/04/how-to-read-multiple-rc-channels-draft.html

The problem I am having is this uses a library and I have downloaded and installed the proper library, but it's not working. I try to compile and i get " 'PCintPort' has not been declared ". I've also noticed that when I try to put the library in the code with the drop down menu it just puts a blank space in there instead. I tested other libraries and they will put in the lines of code in properly (ex. #include <EEPROM.h>).

So does anyone have any idea what is going on here? I am very confused, I've tried using both the latest stable IDE and the beta. Deleted the library and installed different versions. I'm at a loss.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Nick,

    I just tried on a fresh install of Arduino. I added this version of the library: https://github.com/asheeshr/PinChangeInt by placing it in the Arduino 'libraries' folder. It compiled fine. If you already have a copy of Arduino running when you copy over the library, then restart. If your Arduino installation is seeing the library correctly then you should also see the PinChangeInt examples under File->Examples

    Cheers,

    James

    asheeshr/PinChangeInt
    A fork of the PinChangeInt library hosted on Google Code. This is usable in projects across multiple files. - asheeshr/PinChangeInt
    • Thank you for the reply.

      I have been following this procedure to load libraries into my IDE. I've tried many different versions of the IDE also. They came out with a new version of the library yesterday and it didn't work either. Yet my labmate, she is able to compile the code just fine like you and another person on another forum.

      I am thinking that something outside of the IDE is influencing this. I try google search and can't come up with anything so I'm trying every forum related to the items I'm working with.

      So far I've tested this on 4 different computers. Every computer I test it on the library won't reference when I compile. I've tested this on 3 windows 7 computers and an XP.

      • Nick,

        There must be something you are doing. I just tried it on an XP machine and it worked fine.

        What is your 'sketchbook location' under File->Preferences?

        Where did you place the PinChangeInt library?

        Does PinChangeInt show up when you select File->Examples?

        What board are you compiling for?

  • An update and a bump I have found a few people that can compile this code but every computer I try to do this on it will not work. I have done just about everything imaginable to clean up my computer to get rid of anything that might be interfering except a complete wipe since I need an external to back up some things. Anyone know of any known programs that interfere with the Arduino IDE or have been known to if they start to corrupt?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
2 hours ago
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
2 hours ago
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
2 hours ago
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31, 2021
More…