RFD900 makes servos jitter

Hi all,I have 3 planes with APM 2.5 units and one set of RFD900 modules.In any plane I choose, I get slight jitter in the servos when I turn on the RFD900 radio.So far I have installed a ferrite bead at the radio, added 0.1uf and 100uf cap at the radio and shielded the wires going to the radio.I also tried running the radio from a different power source to no avail.If I disconnect the tx and rx wires from APM but still have power applied to the radio then the jitter disappears so the noise seems to be coming through these wires.Any other tricks to try? The radio is on a shielded lead about 30cm (12inch) from the APM2.5

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • I have moved it as much as I can. The jitter never goes away completely unless I disconnect from APM. I would wager that an optocoupler on the tx and rx lines would fix it. Yes the cable from APM to rfd is shielded.
      • Is this happening with pixhawk as well or only APM? 

        • My pixhawk is in the mail. So far I have only tried APM
          • Those radios have quite a distance. I had a similar problem and turned down the power on the radio a few dB. Not the perfect solution but it does work.

            • Hmm... this is not good... How do you turn the power down? in MP? 

              • I've had that jitter too. Keep in mind it really isn't anything to worry about. But I did end up turning mine down a little. Yes in MP. Do not connect like you normally do. Instead click on 3dr radio. Then click on 'load settings' make sure you copter is powered on. it should load the settings for both the radios. The one you want to turn down in the remote. It's probably on 20 try turning it down to 14 see if that helps. You hit save settings to send it off to the radio in your copter. Don't  change anything else or it could get complicated :] 3702906989?profile=original

                • Thanks for that. I decreased from 30 to 28Db. Jitter decreased substantially. Will try adding caps now.
              • In MP go to the "Initial Setup" tab and then with MP not connected select "Optional Hardware" and "3DR Radio". With the radio connected to your computer and the radio on your plane powered up click on the box at the top that says 'Load Settings'. Make sure you have the correct comm port and baud rate selected in the upper right before you do this but do not click the Connect button. You should see the settings for the two radios load in to the settings. In the right window which is is the 'Remote Version' lower the Tx Power setting. Click 'Save Settings' and you are done.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
yesterday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
yesterday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…