RFD900, RFD900+ - New long range radio modem

Hi All,

I would like to introduce you to a new radio modem that we developed for very long range datalinks!


Some of the key features of the RFD900 are as follows:

  • Multi point and point to point link capability.
  • Long range >40km depending on antennas and GCS setup.
  • 2 x RP-SMA RF connectors, diversity switched.
  • 1 Watt (+30dBm) transmit power.
  • Transmit low pass filter.
  • > 20dB Low noise amplifier.
  • RX SAW filter.
  • Passive front end band pass filter.
  • Open source firmware / tools, field upgradeable, easy to configure.
  • Small (30 x 57 x 13 mm), light weight (14.5g).
  • Compatible with 3DR / Hope-RF radio modules.
  • License free use in Australia, Canada, USA, NZ.


These modems are designed to support long range applications, while being easy to use and affordable.  

These modems have been flying in various platforms and have demonstrated excellent performance in real applications. 

RFD900 modems are now available at: http://store.rfdesign.com.au

Support within APM planner and the radio configurator from Michael Oborne is already available.

It works seamlessly with APM planner, all radio Mavlink parameters are available.

Update, December 2014:  The RFD900+ with improved specifications is available now at:


Seppo Saario



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • http://rfdesign.com.au/documentation/sik-at-commands/

    SiK AT Commands
  • Sooo... this is just fabulous... :(

    My 868 config started as such, with RFD config tool v1.6 (before uploading firmware):


    and then settings after uploading multipoint firmware:


    So the new firmware is on, with factory default settings loaded. And for most of the parameters I can reset them, except for upper and lower frequency channels. I only have the option to set RFD900 modem channels. So then tried to load the parameters through 3DRRadio config (where I will be able to type specific channel frequencies into the dropdown label), but an error occurs when I even try to read the settings. All the text fields are not populated:


    So now I basically need to crash course how to edit them through AT command in a console. HyperTerminal didn't provide any feedback after I tried entering config mode of the modem (+++). It only worked (replied with 'OK') after I sent the command through a serial port connection via C#.

    Isn't there an existing interface out there for the 868 modems? I don't really want to write and debug a c# application for this

  • Hi Pau,

    The 868 does not work with the standard firmware. Use the multipoint firmware instead, apperently it handles synchronization better. The only downside is that you loose the logging of the link quality so it is harder to debug the telemetry
  • can you post a pic of your radio settings ?

  • Hi guys, wow this thread is huge!

    I don't know if it has already been mentioned on the previous pages, but I need some help with my RFD868+ links please. I bought two pairs of links from RFDesign (the other pair being RFD900+), but it seems that all the links on RFDesign's site for the RFD868+ modem points to resources for the RFD900 modem.

    And now, as it happens to be, my RFD868+ modem pair keeps breaking link and loses signal quality: 3702306913?profile=original

    I have even hooked up a spectrum analyzer just to see if there's some ridicules irregular interference in the area from external sources, but the band was clear.

    So as a first question, can anyone please point me to correct documentation, firmware & software config links I can use to debug my 868 modems properly? Or let me know if all the resources are identical for the two link versions? 

    The second question then, does anyone know what I should try to fix it? (It does not look like there's obvious hardware faults)

    Any help would be much appreciated. Thank you

    RFD 868+ Modem
    RFDesign designs and manufactures the Antennas, RF Electronics and the RFD900 radio modem
  • Glen, take a look here on the QGroundControl support forum.
    I found a post exactly like yours.
    Google Groups
    Google Groups allows you to create and participate in online forums and email-based groups with a rich experience for community conversations.
  • Yes it is strange that I have the modems working with Mission Planner, so that tells me that there is nothing wrong with the RFD modems but when I try to use it with QGC I get nothing so it must be a setting or parameter or something like that.

  • Hi glen, when you say "via USB", you mean USB to flight controller or USB to the RFD900u?

    I have only a few months of experience with the radio modems, pixhawk, and mission planner. (A 'lil bit o' QGroundControl.) I do have 30 years experience providing technical support, so there's at least a chance I'll be able to help.. if I can't figure it out, I will try to make sure we've got all the relevant details for the others reading this.

    I know how it feels when a question gets overlooked!
    I'm also going to view this on a real computer and see if I missed something obvious.
    I just reread a bit and I didn't read it correctly.. so I will definitely have to use a different computer!
    It's clear you mean USB connection works but serial radio modem does not.
    I would normally just delete my post and redo, but thought you'd appreciate a knowing you aren't being ignored and you will get it working.
  • Great thanks John, hopefully we can work out what's happening.

    Here's my current setup I'm working on.

    Pixfalcon FC, Hexa X frame. ESC Blheli Oneshot. M8M GPS, Frsky D4R-II Rx, Taranis, RFD900u, 600mw VTX for FPV.

    Here's what I find with PX4  and QGroundControl.

    I get telemetry feed back to QGroundControl only when connected with USB but nothing when plug to RFD900u Ground modem.

    But with ....AP3.4-r5 and Mission Planner

    Telemetry all works.

    So why don't I just use AP3.4-r5 and not PX4? Craft flies with PX4 but I have no telemetry. Craft does not fly with AP3.4-r5 but I get telemetry.

  • Glen, I can try to help, I see quite a few posts, and it might be better to post one more that sums up whatever trouble you are having. For me especially, this site's forum has the strangest fonts.. I can barely read more than a few lines without eye strain. (See attached screenshot!)


This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21