Hi all. I have a serious RSSI dropout and “Telemetry Lost” issue which I think is a little different from previous older posts mainly because I still have control of the drone, althought it is still related to range. I am hoping to find others having this problem and perhaps find the solution.

 

Our Telemetry Setup is:- Radio is Taranis Plus with 2.0.17 (opentx-taranisplus-noheli-lua-en). Drone has a X8R receiver, Teensy Mavlink and Pixhawk with custom fw 3.2.1. All has worked perfectly for a year until we had to change our Taranis Radio to a new Jan 2017 production.

 

The problem I am seeing is that as I fly out and get to about 500m the RSSI suddenly drops from about 55 down to zero, and we get "Telemetry Lost" and most annoyingly everything on the Lua dashboard resets to zero. We can still control the drone, and keep flying further away and the RSSI may come back (Fresnel Zone?) but distances data starts from "Zero" again. If I am correct RSSI is a measure of the Signal strength from the controller to the drone, but there is no measure for the signal strength coming back.

 

The problem started when we had a failure with our older Taranis Plus and replaced it with a newer one while we tried to get Frsky resolve the warranty issue by supplying a new main board. Great Radio and long story so won't go there as not so relevant. In the meantime I purchased a new XD9p new from FrSky (Jan 2017 production) and loaded in with the original firmware 2.017 so that the Teensy fw and Pixhawk fw were all matched. I though all was OK until this range RSSI dropouts started. I have done the following to help narrow down the problem:-

- Doing Range tests in range mode was not so representative, so had to fly out the distance.

- Updated internal XJT and X8R firmware - no  difference so returned to original fw

- Tried moving the Drone X8R PCB antennas around and made no difference so resorted to the original setting.

- Tried a friends Taranis Radio (about 6 months old) and it worked full range as far as I could see, so narrows down to a XD9 radio problem

- Replaced the internal XJT module with the XJT module from my older "faulty" radio and it worked perfectly, so narrowed it down to the XJT module. Kept XJT firmware as original.

- Got a replacement XJT module (FCC version) from FrSky but it did not work, perhaps it could have come from the same batch as the new Jan 17 Production radio, or had different firmware.

My initial conclusion is that the receiver section of the radio may have poor sensitivity.   I came to this conclusion because the link from the XD9 to Drone is good, but link coming back is questionable. I don't believe the X8R is transmitting any weaker and have swapped out with other X8R receivers to confirm that. Swapping the XD9 with known good radios worked. And swapping the internal XJT modules with known good modules worked.  I have read older posts that suggest resetting to factory FW helps and some batches have had fw messups. Not sure how to do this but I have (by default) had to load in older firmware fw to work with APM 3.2.1 and Teensy3.2.

It's unfortunate having the dropout issue, and made worse by the telemetry data getting reset.

Any assistance to help me resolve this would be really appreciated. 

Views: 415

Reply to This

Replies to This Discussion

Hi,

Have you resolved this problem? I am still looking for a solution for a problem like yours.

regards,

Eladio

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service