RSSI Setup Dragon Link

Ok I have the pixhawk and dragon link installed on my aircraft. What is the best way going to program my RSSI. I am getting a read out of 65 on my PFD and when I unplug the cable for RSSI I get 32. 

Dragon Link suggested putting the plane about 50-60 feet away on High setting and set it so it reads around 99. Then put the dragon link in range test mode and set the low. Do I adjust the RSSI Voltage parameter on Mission Planner? I played with it some on the high in and got it to show 99, but not sure how to adjust the lower end. Or is this even right? 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi I may found a way to help you:

    1. Connect DragonLink RSSI analog out, Pin8 to Pixhawk SBUS (SB).
    2. Connect the Pixhawk on your PC, open Mission Planner in  Full Parameter List and find the RSSI options PIN and RANGE to set the values below:
      1. RSSI_ANA_PIN: 103
      2. RSSI_TYPE: 1
      3. RSSI_PIN-HIGH: 3.3

  • hi everyone 
    i need your help pls
    i have a pixhawk running 3.7.1 plan 
    and dragon link v3 
    i connect every thing and i am using my laptop to connect to pixhawk throw dragon link Bluetooth to my pixhawk for mission planer. and its all woking just fine.
    my onlly problem is the rssi its not show any change even if i turn the dragon link off its read 100% all the time ?
    how can i make it read the correct rssi from dragon link in mission planer ?
    I set IN PIXHAWK
    RSSI_ANA_PIN : 103
    RSSI_CHAN_HIGH : 2000
    RSSI_CHAN_LOW : 1000
    RSSI_CHANNEL : 8
    RSSI_PIN_HIGH : 3.3
    RSSI_PIN_LOW : 0
    RSSI_TYPE : 2
    AND IN DRAGONLINK RX
    RECEIVER OUTPUTS
    CH7 : PPM
    CH8 : ANALOG RSSI
    BUT STILL NOT WORKING ITS JUST SHOW 100%
    what parameters do i have to change and what numbers i have to set there ?
    THANKS
  • Dragonlink uses 3.3V RSSI.  Make sure you select that on your Pixhawk to get the proper range.

    WIth current firmware ("Next gen" from June or 2014 or later) the Dragonlink RSSI goes from 0-3.3V over the useable range.

    Dragonlink will be working fine with an RSSI as low as 10% or so which requires you to be many 10s of kilometers away with the stock antennas.

    I tweak the 100% value using the settings in the MinimOSD-extra firmware.

This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…