Sending a new waypoint with Mavlink


I am currently working on a project to autonomously fly a quadcopter by having an arduino mega board send waypoints to the APM.  I have looked through the Mavlink API and noticed that there is a a function "mavlink_msg_mission_item_send" which I have been trying to use to send waypoints to the APM.  However when doing so, nothing seems to happen, and the waypoints do not get set.  Has anyone tried anything like this and had any success? Is there some other function I should be looking into to correctly send waypoints to the APM?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello guys, when I tried to compile the arduino mavlink on my arduino uno, I found this error" # error Must include FastSerial.h before the Arduino serial driver is defined".But I have already include Fastserial in my library, why does that happen? By the way, I am following this tutorial:

  • Hey Ben,

    I've been following your posts, have you made any progress with this idea?



  • did you make and progress with this Ben ?

This reply was deleted.