setup fbwa mode on flying wing

Dear all,

Apologies this is probably a dumb question but I have not done this before.

I am trying to setup my skywalker X6 with pixhawk.  The pixhawk is connected via sbus to my taranis receiver (X8R). Everything is working as intended in manual mode (I have the elevon mix set on my transmitter - note if I do not do this it does not work correctly).

When I switch to FBWA the control surfaces seem to be confused. When I pitch the plane it attempts to correct by banking (i.e. ailerons) when I roll the plane it appears to apply an elevator correction.  It appears to be confused about which axis is which.

The servos are in the correct outputs as documented in the wiki. I have tried every combination of the pixhawk elevon mix on the rc calibration page but I am getting no joy,

I realise this is probably simple but I have run out of patience.

Any help would be appreciated.

Many thanks

Darrel

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Keep the taranis setup AETR (like apm is on 1-4ch) I had heaps of problems trying to get my X6 elevons to work properly. No luck... I could get it working in fbwa or stab, then when i would switch to manual, it was all messed up. Then i would play with the taranis until i got it working in manual, switch it back to stab, and poof, not working again. So here is the solution...

    Set up your taranis like you would any other 4ch plane. Then use mission planner to get the control surfaces working properly in stab and fbw modes. Switch to manual, go to your taranis. If it is not working properly, it means either your aileron and elevator channels are mixed up, or they just need to be reversed. It will not work if you use elevon mixing on the taranis. 

    Unless there is something i dont know about pixhawk, or rc passthrough settings, this should work. I spent prolly 2 days trying to figure that out. (full days)

    • When I try with no mixing I get each elevon acting independently, even with elevon mixing turned on in mission planner.  I can only get manual to work with the TX mixing. I tried with the AETR setup but no mixing happened in manual.

      Switching to FBWA mode, using various combinations I now have surfaces all going the wrong way. No combination of reversing cures this problem. 

      Does it really have to be this counter intuitive? It is driving me nuts.

      Craig can you tell me exactly how you got this to work - assume I know nothing!

      • Ok, so just set up your taranis like it was a normal 4ch airplane. Then leave it. Hook up the elevons to aileron, and elevator channels on your pixhawk. (I dont have a pixhawk just fyi) Put it in FBW mode. Play with the elevon settings until you get it to work properly in a fbw mode. You might have to go into full param list and change the elevon settings from up/up to up/down or down/up or down/down. I forget what the param is called exactly, and i dont have my plane here to plug in. It is near the "E" section of the list anyways right there with the other elevon settings.

        Once you have it moving proper in fbw mode, switch to manual. Move your sticks. And note how the elevons change. if you move your stick to the left and right, up and down. depending on how they move, you might need to switch the elevator and aileron channels inside your taranis. If they are then reversed, reverse the channels. DO NOT USE ELEVON MIXING on the taranis, whatever your logical brain tells you. Believe me... I was pulling my hair out.

        Beyond this explanation, there is not much else i could do unless i was on the phone and you explained exactly how the surfaces were moving with each stick input. or you made a video i could watch.

        Hope this helps!

        • Thanks Craig,

          I 'think' both FBWA and manual are working now (I will find out when I try to fly this afternoon).

          I had not tried to use the full parameter list before, I relied on the buttons on the radio page.  I got it working in FBWA mode quite quickly but manual was more cumbersome. Eventually had to reverse the channels on the TX and by trial and error eventually got them going in the right sense.  I can't say the parameter naming strategy is intuitive but I guess it made sense to those who wrote the program.  Anyhow hopefully it will just be fine tuning the gain parameter from here on in.

          Many thanks for your help, it is much appreciated.

           

  • Moderator
    If the tx still is enabled for elevons then your APM is not set correctly, that's why you are getting a very small movement STAB is stabalise mode. Check the wiki for elevons
    • I will try without TX mix again tomorrow.  I would have checked the wiki but there is no access on the flying field!  I have much to learn but I am making progress.

      How do you find the X6? We had some problems finding the right motor and the exposed prop made me nervous so I have a working bungee launch system now, which works well.  My airframe looks like a car crash but it will still fly. I have a new one coming. Once it is flying it seems great and it will carry my NEX5 and a 4S 5amp battery without a problem (although my testing will be with a canon 260). Hoping to get some photos done soon.

      • Moderator
        Check the servo output leads are I the correct outputs, they cross over out1 goes to the left win, out2 goes to right wing!
  • Thanks.  With the help of a colleague at my local flying club we were able to get the elevons working correctly in stabilise mode but the throws are too small i.e. the plane remained level but did not respond to intended roll or pitch changes from the TX. I need to do some reading on the parameter settings. 

    Incidentally another newbie, related(?) question - what is STAB ?

    Also for information, I did not need to omit the mixing in the TX and the plane still works as intended in manual mode.

  • Moderator
    You need to disable elevon mixing on the Tx and enable it in the controller, adjust the directions and responses in STAB to be correct mhen you move the X6 on the ground. Then adjust the Tx reversing to give the correct movements in MAN. I am testing my X6 later today. Have fun
This reply was deleted.

Activity

DIY Robocars via Twitter
16 hours ago
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
Wednesday
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…