Spline waypoints missing from Mission Planner

I did a new installation of the latest (v 1.3.28) MP on a PC and SPLINE_WAYPOINT isn't listed in the command drop down list.  Further, if I check the Spline box before clicking on the map, it drops a waypoint at 0,0 Lat/Long.

The first installation was on a Windows 7 machine.  I subsequently tried it on another 7, then on a Windows 10 technical preview PC.  They all behave the same.

This only seems to happen on fresh installations.  I use two Windows 7 laptops for flying and they were both updated to 1.3.28 and work fine.

I'm hoping someone else can try a fresh installation and verify whether it works or not.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • 3D Robotics

    That makes perfect sense, Michael.  Thanks!

  • Thanks.  I see I should've connected my quad to it.  The computers are at work where I don't have my quads but I was able to switch it to multicopter mode by reviewing my telemetry logs from droneshare.

  • Developer

    MP displays a list of options based on the last connected device type.


    what you where seeing was the plane list. connect to a quad, and the list options will change.

  • 3D Robotics

    OK, I solved this by installing Mission Planner on the new machine, then deleting everything from the Programs/Mission Planner folder and copying in the contents of the folder from my old machine.  Very strange.

  • 3D Robotics

    I can confirm this.  In my case, I am installing on a virtual Windows 7 machine, but I see the same thing as you.

This reply was deleted.


David Hori liked Isabella Domi's profile
gotham liked gotham's profile
Dec 3, 2020