• Thanks I appreciate the acknowledgement. But it was actually Michael Osborne that brought it to my attention.So kudos to him for helping a bunch of guys out. good Luck Patrik.

    Love to hear how you make out.

    Happy new year

  • was there ever an answer to this as I have the same issue

    • If i remember correctly you must connect within 3 seconds of board power up. If not it will just display weird characters in the terminal window.

      • in the 3.2 version the cli was removed. So I back leveled the APM and then the CLI worked fine. I wiped the eeprom and reinstalled the code The problem didn't go away however so now I am looking to see if I have a compatibility issue with the ESC's. 

        • This reply was deleted.
          • haha sorry man I had the same reaction. I had installed a miniapm and thought oh crap its F#$ked.

            I worked for days trying everything and then oh really disabled..really..dang..ok looking at a problem that doesn't exist. sigh

            good luck

            • My APM gives me the same gibrish and nothing helps.

              I tried everything that was said above but nothing helps and no logs can be downloaded.

              I'm using it on a fixed wing setup. It crashed today when I switched to RTL and I need to know why.

              • Admin

                @Crazy Cow,

                The APM version of the latest ArduPlane firmware has had the CLI eliminated to conserve memory.

                You can get to the tlogs and data flash logs here Link 


                TCIII AVD

                • Thanks for the info. I'll dig into it.

    • Developer

      CLI is removed from arducopter 3.2

      • I guess the only option is to go to a back leveled version as I was trying to do an erase and reset to factory specs due to weird issues I am seeing with the apm.

        Saif Azmi_
        Saif Azmi_
This reply was deleted.