Sudden APM.1 failure - help !

Sorry, posted this inadvertantly in quite the wrong section before

.Can anybody help me ?  I have recently uploaded Arduplane 2.28 to my APM v1 2650. I uploaded waypoints and geo-fence data to it using Mission Planner  1.1.26 but now I have a problem.  I do not see the leds flashing for the imu calibration after start up – the APM goes straight to LED A (green) solid. I cannot get attitude data back to MP either via the USB link or by telemetry  (neither does it work with the HK GCS). If I run an IMU test with the CLI/Terminal program I seem to get sensible data. All other aspects of the APM seem to function correctly i.e. writing/reading the eeprom , running tests for other functions under CLI, ppm input and servo operation.

What could have gone wrong?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Well I've persevered. Erased the 2560 chip  and re-installed bootloader. Re-loaded AP v 2.28 with Mission Planner - same problem!

    But here's the odd thing:

    I loaded the Arducopter code (also using MP) and hey presto the board functions perfectly. IMU data shows up on MP screen and telem works.

    I go back to Arduplane and - yes you guessed it - back to the same problem.

    I begins to look to me as if it's a code/MP problem and not the APM board at all.

    Has anyone else experienced this, or does anybody have an idea as to what could be going wrong ?

    At least I know that I don't need a new APM board.

  • Admin

    Simon,

    Did you clear the EEPROM after the upload?

    Just a thought.

    Regards,

    TCIII

This reply was deleted.

Activity

DIY Drones via Twitter
Using ArduRover with an RTK GPS https://ift.tt/2N9I3RO
18 hours ago
DIY Drones via Twitter
yesterday
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
Friday
DIY Drones via Twitter
Thursday
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Thursday
DIY Robocars via Twitter
Thursday
David Hori liked Isabella Domi's profile
Jan 12
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Jan 11
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Jan 11
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Jan 11
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
DIY Robocars via Twitter
An interesting line-following simulator to use with with your robocars: https://github.com/ron-grant/LFS
Dec 23, 2020
DIY Robocars via Twitter
Dec 23, 2020
More…