Throttle cut in FBW-A

Hi all, 

After a couple of successful autonomous BIXLER flights, I felt I could securely move to the bigger Skywalker, which had it's maiden flight yesterday: APM2, Arduplane 2.66, Skywalker default param, 3DR UBLOX, no airspeed installed though.

Since I realized through some former reading that the calibration of the APM on the field is quite important, I used a bubble level placed on the flat area at the back of the prop (as soon after I puggled the battery)

I then tried flying in manual... perfect! not much trimming needed.

Then move to stabilize...perfect! the plane returns to level and straight flight asa you release the stick. Wow, I'm staring to get very excited... the default APM parameters loaded for this plane ( are great and it really stabilize perfectly well.

I then decide to test Fly By Wire A (since no air-speed installed). And that's when I got into trouble. No more throttle!.... stick down, stick up, nada.... reverting back to stabilize... still no more throttle!...even more surprising, reverting back to manual didn't restore the throttle.........?????

Fortunately the plane was high enough and not too far away, and I was able, not without stalling once, to get it (kind of) back in one piece - a bit of a hard landing on the nose but just a couple of small cracks...


  • Does anyone have an idea of what is possibly going on here ? it seems strange to me that the throttle isn't coming back when switching to manual, thus supposedly bypassing the APM... maybe someone else would have come across the same issue ? could it be a problem with some of the APM parameters ? (I doubt).. any clue on this issue would be welcome!

  • what are the meaning of the UBLOX GPS lights ? I get one solid red, then quite quickly an additional blinking blue one... I was used to the solid blue from the MTEK, but is it different for the UBLOX ? Also, can someone confirm that in the proper way the UBLOX should be setup, the led are then sitting under ? (unlike the mtek)

Thanks for any help

PS: can share any tlog file unfortunately - it seems none have been recorded for this specific flight :-\

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi againg,
    although I have seen now that "reverting back to manual didn't restore the throttle.........?????" I can't explain it. But, anyway, check what I tell you
  • Hi Manu,
    I had the same surprise in my first test flights with my maja but I have found an explanation that maybe helps you. Do you now if your plane is flying over default height or home height when you have no throttle? If so, maybe your plane cuts throttle to reach that default height (descending). That is what happened to me, as simple as I tell you. Check it and If your plane do it again, be patient (and be ready to recover manual flight mode if necessary) and let it glide to default height (if my maja did it your blixer should glide much better) and then it should start throttle as required.
  • Hi online experts,

    Coming back to you on this annoying problem I'm having, the motor stops when switching to FBWA or RTL..

    I did a recalibration of the HK ESK as you suggested Ravi (which was a really good idea in any case), but unfortunately this didn't help my problem. Same motor cut when switching to FBWA, but also when switching to RTL, as you can see in this test

    My worry is that I had all this modes successful when the APM was recently on the Bixler2 (with the Bixler default config), but now that I have transfered it on the Skywalker (with the SW default config), I get these annoying problems :-\

    I'm thinking that if it was a problem with the ESC, then it either wouldn't work at all, or would only work in MANUAL, but it does work ok in STABILIZE mode (whatever the throttle level is)...

    So I tend to think that the SW param file could potentially be the source of the problem. But I guess it has been tested already by others, so I really doubt...

    One thing I noticed when I got the plane in my hand after it landed in stabilize mode, I noticed that the APM compensations to my movements were not any more progressive as it's the case usually, they were rather 1 or 0, therefore full down or full up for the ailerons, same for the elevator and I guess the rest... what could it mean ? has the APM gone wild ?


    What else, as some famous guy would say ? any idea someone ? I'm really stuck in a dead end...

    I'm receiving another ESC in 3-4 weeks (standard HK delay here..), so I will try, although same model...

    In the meantime don't hesitate if you have any track...

    Thanks in advance guys.

    PS: I have the TLOG file, which I'll post shortly

  • yes, that is correct procedure to calibrate. make sure that you when the throttle is up you lower the stick immediately after the first beep. beyond the first beep the ESC goes into prorgamming mode and then you cannot calibrate it.

  • i am not sure but try recalibrating the throttle by putting the radio control trim for throttle fully down. some ESC's are very sensitive end most PWM value. by lowering the throttle trim you would increase the lower end PWM limit. it happened with me with hobbywing ESC's.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25