Throttle cuts in Loiter, Auto, RTL etc.

Hi everyone,
First time post, happy to be here :)

My problem is thus:
I'm flying my Bixler 2 manual, and everything is fine. Stabilise mode works perfectly. Super smooth and stable with the default bixler PIDs from the wiki.

However, when I switch to loiter, circle, auto, RTL or FBW B, the throttle cuts out. The navigation works well and it flies to all the waypoints, but without throttle. I switch back to manual an I get throttle control back. Here is what I've tried:

Airspeed sensor enabled.
Airspeed sensor disabled (both 'use' and 'enabled' unchecked)
ALT_CTRL_ALG in 0,1,2 and 3.
FBW max and min speeds and well above stall speed (16m/s)

Now what really worries me is that I enabled throttle suppression, and it still cut the throttle in loiter even though I had my stick at full.

Absolute altitude is not checked, but that shouldn't matter in loiter anyway.
Also, in FBW A, I'm in charge of throttle, but it only has a range of like 0-10%.

The frustrating thing is that in my hand and on the bench it goes to full throttle in auto and loiter, but in the air it cuts! So I tried auto in my hand, and the moment I threw it, the throttle cut.

Any ideas?
Thanks,
Patrick

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    Try to recalibrate your radio in the planner, sometime take wrong value in the CH3 channel, check the RC3_MIN and MAX in the full parameters list, compare them with the other RC parameters.

  • Never mind. I was trying to solve this problem for a week, and like always, I solved the problem myself as soon as I asked.
    I had CH3 reversed. So when the APM was simply passing through the signal in manual mode everything was fine, but throttle was backwards in auto modes. This is why it throttled up in my hand and cut when I launched it. It should be the other way around.

    Tim, I was going to say what version I was running, but I don't know how to find out! I couldn't find it anywhere. How do you find out? Anyway, the version I was running didn't have AS autocalibrate but I only installed it like last week so I'm guessing 1.74? I updated the firmware to 1.76 in attempt to fix the problem. Needless to say it didn't help reverse the throttle back.

    • Definitely throttle reversed parameter. 

  • What version of Ardupilot are you running?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race is next Saturday. Compete from home using the @donkey_car simulator -- no physical ca…
13 hours ago
DIY Robocars via Twitter
RT @RoboticMasters: Students from @Sydney_Uni working hard on improvements and changes to @donkey_car simulator. @diyrobocars @adafruit…
13 hours ago
DIY Robocars via Twitter
Practice virtual race this Saturday; the real thing will be on Oct 3 https://www.meetup.com/DIYRobocars/
Wednesday
DIY Robocars via Twitter
Wednesday
Derrick Davies liked lisa TDrones's profile
Wednesday
DIY Robocars via Twitter
Sep 21
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
More…