Hi everyone,
First time post, happy to be here :)

My problem is thus:
I'm flying my Bixler 2 manual, and everything is fine. Stabilise mode works perfectly. Super smooth and stable with the default bixler PIDs from the wiki.

However, when I switch to loiter, circle, auto, RTL or FBW B, the throttle cuts out. The navigation works well and it flies to all the waypoints, but without throttle. I switch back to manual an I get throttle control back. Here is what I've tried:

Airspeed sensor enabled.
Airspeed sensor disabled (both 'use' and 'enabled' unchecked)
ALT_CTRL_ALG in 0,1,2 and 3.
FBW max and min speeds and well above stall speed (16m/s)

Now what really worries me is that I enabled throttle suppression, and it still cut the throttle in loiter even though I had my stick at full.

Absolute altitude is not checked, but that shouldn't matter in loiter anyway.
Also, in FBW A, I'm in charge of throttle, but it only has a range of like 0-10%.

The frustrating thing is that in my hand and on the bench it goes to full throttle in auto and loiter, but in the air it cuts! So I tried auto in my hand, and the moment I threw it, the throttle cut.

Any ideas?
Thanks,
Patrick

Views: 495

Reply to This

Replies to This Discussion

What version of Ardupilot are you running?

Never mind. I was trying to solve this problem for a week, and like always, I solved the problem myself as soon as I asked.
I had CH3 reversed. So when the APM was simply passing through the signal in manual mode everything was fine, but throttle was backwards in auto modes. This is why it throttled up in my hand and cut when I launched it. It should be the other way around.

Tim, I was going to say what version I was running, but I don't know how to find out! I couldn't find it anywhere. How do you find out? Anyway, the version I was running didn't have AS autocalibrate but I only installed it like last week so I'm guessing 1.74? I updated the firmware to 1.76 in attempt to fix the problem. Needless to say it didn't help reverse the throttle back.

Try to recalibrate your radio in the planner, sometime take wrong value in the CH3 channel, check the RC3_MIN and MAX in the full parameters list, compare them with the other RC parameters.

Definitely throttle reversed parameter. 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service