Transmitter calibration doesn't save ?

i have done the transmitter calibration with the configurator,

all seems ok and it gets the right values and positions,

i hit save,

but then when i disconnect and reconnect the copter to USB, the "transmitter" screen in the configurator screen shows all values round ( 1000 to 2000) instead the calibrated max and min.

 

in flight, when i arm the motors no one start to spin,

i add some throttle and some begin, and i have to add some more throttle to get the others spin.

takeoff and flight is perfect.

 

yes i've also done esc calibrations through CLI.

the problem started as i've re-loaded the ardupirates NG code yesterday with the camera stabilization turned on, so i had to re configure all.

 

thanks for help!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • The transmitter thing is normal.
    Motors not spinning when arming is caused by low-throttle point set too low (<1000, typically). It happens sometimes. To solve it, run the low throttle calibration in CLI.

    Re: magneto and offsets...
    Two stupid questions:
    1) does your Windows locale use decimal point or decimal comma?
    2) you did click Update after setting the magneto on in Configurator, right?
  • so what exactly is your problem?

    - it flies

    - it behaves as expected

    why do you have to reconfigure? settings remain when reuploading code....

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Jun 25
DIY Robocars via Twitter
Jun 25
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
More…