Ublox Neo-6M GPS doesn't work when i power APM through battery, but works through usb (Solved)

Greetings. I hope this is the correct category for this post.

I've recently assembled my quadcopter. I have APM 2.x with external compass + gps module, namely Ublox Neo-6M. When i connect the APM to the pc through the usb port, it powers the receiver and the gps just fine. However when i try to connect the battery (through the power module) the GPS led indicator stops blinking and gps signal is lost. From what i see on mission planner though the compass still works as the mx, my, mz readings update as i move the copter around. This occurs when i have both usb and battery connected, or when the apm is only battery powered. So the problem is that gps doesn't work when APM is battery powered. What could be the cause of this? By the way Jumper 1 is unplugged.. If anyone could help a bit i would very much appreciate it. Thanks in advance!


I resolved the problem. The issue was that i connected all 4 esc's power cables to the apm, while i didn't need any, since the power module was providing power to the apm and it's peripherals. This probably caused a lot of interference and whatnot in the assembly and as a result the gps couldn't lock. After i removed the cables i instantly get a fix (<20s) with very good stats as well. I tested both indoors and outdoors. Great performance overall. Note that i updated GPS with the file here (i had already done that before though. Just mentioning). Hope this helps someone.

Views: 1107

Reply to This

Replies to This Discussion

*Update 2*

The *Update*  part could have helped it wasn't the crucial step to get it up and working. After i did what i mentioned above the problems were lessened, but persisted. What i did afterwards and fixed it completely was to increase the ground plane of the gps. I did that by putting aluminum foil underneath and almost doubling the effective ground plane.

When APM is connected through the usb port, the ground connects to the ground of the PC, which is the grounding of the facility you're in and that's the perfect grounding conditions. But on battery power, the ground is not so well "adjusted".

From the moment i did that everything was perfect. I don't have the 3Dr labelled GPS unit, but a chinese one. I have fixed it a long time now, but forgot to post the answer. Maybe this might help someone.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service