Unable to calibrate flysky radio using mission planner software.

I have built a kit quadcopter using the apm  2.8 flight control. Using the mission planner software I attempt to set up the quad for flight. I get up to the point where it wants to calibrate the radio. What happens is as soon as I power on the radio, the mav link disconnects. I have the latest firmware installed and the transmitter is bound to the ia6 receiver. This happens with both the wizard and the manual set up. I have reloaded mission planner and tried the set up on different computers with the same result. Very frustrating. If I skip the radio calibration I can arm the quad and get the motors to spin. The problem is that the quad pitches forward and crashes when taking off. I'm a noob but not a total noob and have successfully flown other quads. Any help would be very much appreciated..TM

Views: 83

Reply to This


Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service