Vtol issue setting frame class with firmware arduplane 3.8.0 beta 6

I cannot get the the frame class to quadplane. each time I set it in full parameter list and write params it looks like it saved, but as soon as I reboot the flight controller the setting is back on HEX instead of quad.

I am building a Quadplane and want to use the latest beta firmware (arduplane 3.8.0. beta 6) 

After installing the firmware I go to full parameter list and enable the quadplane functions by setting Q_Enable to 1. 

this all works fine. but then when I try to change the frame class(Q_Frame_Class) to "0" for quad and write params, the setting goes back to hex "1". after a power cycle.

I am using the CUAV Pixhack v3 flight controller but I have also tried it on a pixhawk2.1 cube with the same result. I have also tried plane 3.8.0 beta 5 and its the same.

This does not occur with the older firmware versions like plane 3.7.1 and older.

Has anyone else had this problem and what can I try to resolve this?

I really want to use the beta firmware because of the improvements on the quadplane. 

Views: 198

Reply to This

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service