Weird sound coming from Ardupilot Mega IMU shield/Oil Pan

I soldered on the headers to connect the Ardupilot Mega to the Oil Pan IMU shield.  (I'm still waiting for the 3x8 right angle headers...those aren't on yet)  When I hook it up to my computer via USB, there is a loud, sort-of clicking sound.  You can get the general idea from the video.  If I had to pinpoint the sound, it sounds like it is coming from the Relay.  Any ideas?




Views: 3357

Reply to This

Replies to This Discussion

Tony,

I mated my ArduPilot Mega with the IMU Meg last weekend, but did not experience the clicking sound heard in your video. Have you double checked all of your solder joints? Also, what code are you running on the ArduPilot Mega. Mine was running the ArduPilto Mega Demo program that tests the RC functions.

Regards,
TCIII
I don't get this with either the teaser code or the ardupilot mega demo code so you must have a bad solder or bad part. Have you tried a "hello world" application on there that does nothing?
Odd.
That happens sometimes when the power supply is shorted/overloaded, and it tries to shut off.
Here's what I've done:

Joined the ArduPilot Mega and the Oil Pan IMU minus the 3x8 right angle header pins.
Installed Arduino 0018.
Connected a mini usb cable from my computer to the mini usb port on the IMU while it is joined with the ArduPilot Mega.
Computer successfully installed drivers
Opened ArduPilotMega_Demo and made sure I had Arduino Mega and the correct COM selected
Uploaded the code successfully
In the serial monitor at 57600 baud, "Ch0:1500 Ch1:1500 Ch2:1500 Ch3:1500 Ch4:1500 Ch5:1500 Ch6:1500 Ch7:1500" was output over and over again.

The clicking sound persists through all of this and I think it made the sound before I uploaded code. Every once in a while the sound will stop for about a second and then start again.

I looked at all of my solder joints and don't see any of them connected with each other. Is that what you wanted me to check? I can try to find a magnifying glass and look at them more closely.
looks like low voltage relay chatter. try powering it up with batt without USB connection first or through powered USB hub.
I've got the mega beta board and the new mega shield working, but I do not have that sound issue at all. I've successfully run the teaser code, plus the new arducopter (mega) code, and the beta ardupilotmega_1_0. And so far the attitude gyros/accel output are working great. The code the guys are working on is looking real close to being flight ready... cant wait :)
Have you tried powering up when it's not on a foil bag?
Yes
Adam ,GOOD CALL , that could be good reason as any :)
Tony, check all the above. also run a fine brush to remove a scrap solder some where. inspect the whole board under magnified light. A bad or cold solder might be lurking somewhere
yes?
do you have other way to power it up?
I just have USB right now...no battery
any powered USB hub or regular PC ? try PC if you were using laptop. try changing the USB cable to another one(shorter length)

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service