I have 2 xBee 900MHz with diydrones shields and if I don't remember to unplug the plane side xbee connection when I power up then it sometimes gets bricked where the blue and red lights stay on. I'm getting really good at debricking them in under a minute but I'm wondering if this is normal :-/

 

I'm using the latest firmware in X-CTU.

 

Is this normal?

Views: 1061

Reply to This

Replies to This Discussion

Assuming you're using APM and not the original ArduPilot, that almost always means that you've got a loose connection in the cable connecting them to APM. If a signal comes to the Xbee while it doesn't have power, it will corrupt the firmware. 

 

Once I switched to the custom Xbee cable, I never had that problem again. Those cables should be back in stock next week. 

Yes I am using the latest APM and I made my own cable just like what you have. I will make another one and see if that solves the problem. Good to know this isn't normal :) I know with the arducopter code before it merged with APM, it had that problem.

I don't know if its normal but I have 2 xBee 900 MHz and both bricked during configuration.  My project: botmite.com

I've made a new cable like the custom Xbee cable and will see if the bricking stops.
I made a new cable that I'm sure is ok and on the first try it got bricked. When it gets bricked I know it right away because the blue and red light stays on. This never happens to the ground side xbee on the ftdi cable.

Is this happening because the xbee is getting data before it is ready? That was the problem in the older arducopter code also. I know this has been fixed in the 2.22 APM firmware so not sure why it's happening to me.

Any suggestions?

I've got two or three modems where the RSSI light on the usb explorer board stays lit all the time and they don't work. Might my modems be "bricked"?

That's what mine look like when they are bricked. It only happens on the plane side xbee. I'm using the diydrones shield.

I've made a new cable that I know doesn't have any lose connections but I still have the problem sometimes.

I know that sometimes when I plug in the battery (I'm using deans connectors) it sometimes doesn't make a good connection at first so gets power for an instant and then off and then I get the plug connected good. Could that be the cause?
I have the DIY drones cable and my airside XBee is also bricking fairly regularly as well.
One thing I have noticed, is that if you don't 'disconnect' the APM Planner by clicking on the disconnect icon it seems to increase the frequency it occurs. I also have more occurrences when powering the APM via USB.
I have quite a structured startup and shutdown process now and it only seems to brick when I don't follow the process.

1) Power up the plane and XBee
2) Fire up APM Planner
3) Connect the USB adapter to the laptop.
3) Wait 10 seconds
4) Connect via the APM planner.

For shutdown:
1) Click disconnect in the APM Planner
2) Shutdown the plane (you want to do this cleanly without accidentally applying power again for a short time).
3) Remove the USB cable on the laptop.

When I follow this process, all is good. Occasionally when I forget or do it out of sequence, I brick an XBee.

I haven't isolated exactly why this is but I suspect there may be scenarios where the APM is still running but the XBee has lost its power so signals are still being sent to the XBee.

I wondered if a hardware solution might be to add a small capacitor to the power supply of the XBee so it keeps running for a slightly longer period of time than the APM. This would also 'smooth' over any bumps that might be caused by a dodgy connection or power supply.
I wasn't having any problems with bricking, then, sometime in June, (not quite sure when) I started getting it frequently. I have tried three xbees and two xbee explorers and it happens with all of them, but only when they are connected to the APM, not on the ground side. I have checked and rechecked the wiring (not the diydrones cable but will add one to my next order) and couldn't find anything.

I ended up trying a power switch between the ESC and the APM. If I have the switch off, plug in the main battery to the ESC, and then move the switch to on to power up all of the APM and xbee equipment it is fine. I have also tried a separate BEC and had the same issues (and the same solution). Not ideal, but it works for me.

Andrew

I think that is definitely the cause. The Xbee needs some time to boot up, not long, 1s maybe. If it gets serial data during this time it gets bricked. I fixed this problem in the original autopilot firmware by putting a delay before the init(). In your case it is not real data being sent, but glitches from your power up problem. Xbee gets powered up and the capacitor charged on the adapter. Main power glitches when plugging in deans connector, but Xbee is still alive and sees the serial line drop from 5V and sees this as a 1. With a serial line 0 is 5V and 1 is 0V. Maybe the dropouts are seen as data coming in and since it's garbage data the Xbee gets corrupted or bricked.

Hmmm I didn't think about the planner being part of the cause. I will try your sequence and see if it helps.

I've never been able to brick the ground side either.

 

I'm thinking this is related to inconsistent powering up because sometimes I can't make a clean quick connection when I apply power to the APM and that quick on off on might be the cause. I'm going to start unplugging the full xbee cable during power up.

 

Is there any problem in the booting of the code without the xbee connected and then connecting it after it's booted up?

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service