Wired APM 2.5 behavior. Need some help!

Need some help here.

Have rigged a new APM 2.5 with the lastest firmware and it works fine when just GPS is plugged in.

Hook it up to Flight Planner and all works as expected. Compass is good as well as GPS and accelerometers.

Problem starts when connecting the receiver and servos.

I can control the aileron and elevator from the TX the first 20 seconds. Then the servos starts to be sluggish and finally stops reacting after 25 seconds.
I have nothing connected to channel 3, throttle, but when moving the throttle stick, the other servos make a small "jump" or jitter.
Rudder is controllable all the time.
Also, the compass as well as GPS and accelerometers is far out. Totally wrong.

When I plug in USB between APM and computer the servo control is retained for another 20 seconds, then fades away as previously described.

Power only through the PM.

Jumper 1 connected

Using a 3s 2200 standard lipo.

Battery voltage: 12,3

Measured voltage on Output end of APM: 5,3

Measured voltage on Input: 4,93

Futaba 10c TX

Futaba R6014 HS RX. Have also tried with other receivers, Orange from HK, with the same result.

No 3DR radio connected.
APM firmware Arduplane V2.72
Mission Planner: 1.2.48

Tried with different servos from low end HTX to Hitec and Hyperion. Same result.

Do you have ANY clue whats going on?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • In my excitement I forgot about that. Just checked and no, it outputs the same PANIC message.
    Not sure what to do about it.
    I also notice that it is not possible to go into terminal through 3dr radio. Just a bunch of unreadable signs are scrolling.
  • Yes, I have also tried powering the output bus with a separate UBEC. Same behavior.

    But, according to the documentation It should be possible to power both in and out but from the PM.
    See under single supply setup.

    I suspect that I've got a board with defect voltage regulator.
    Apparently there was a batch of boards with this problem this year.
  • Developer

    The Power Module  should not be used to power the planes servos. The design idea is to keep servos etc... interrupting Vcc.  Have you tried powering the servos using the ESC internal BEC or using a standalone BEC connected to the outputs?

    see http://code.google.com/p/ardupilot-mega/wiki/Voltage#APM_2.5:_Using...

This reply was deleted.