Xbee help (AC 2.0.23)

I find that I cannot connect to the PID screen using XBees. This used to work before.

However, I can see the Sensor/Radio-in/Motors-out screens using Xbee. GCS also connects fine.

When I try the PID config screen, it says something about an ID mismatch and "Port in use?".

So, to summarize:

I can't get the PID config screen to work with XBee.

Sensor output, Radio-in, GCS work fine using Xbee.

 

Everything works with USB.

 

Any pointers as to what I could be doing wrong?

 

Thanks.

 

p.s. since the Sensor view and radio view works, I assume the xbee config (port, speed) is OK.

I also tried reloading code and resetting EEPROM, but the problem persists.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    Chris/Sanjaya,

    I will play around a bit more to see all the possible variations and after everything is 100% proved, I will update our wikis for that.

     

    And yes what i've seen, it is easier just to stay with fw 1002 on those 900Mhz XBee Pro's

  • Developer

    and are you running latest APM-MP?

     

    I have seen this same error few times when jumping a bit too fast between windowses. But as you said, Sensor and radio output works find so it means that your xbee is ok so problem has to be on your computer.

  • 3D Robotics
    Are you closing your sensor screen before trying the PID screen?
This reply was deleted.

Activity

gotham liked gotham's profile
3 hours ago
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…