Xbees not working as they did before

Hi Guys

 

I have been having problems with my new batch of xbees I ordered from sparkfun the other day 3 pairs of

XBP09-DPSIT-156   , when reading the device in the CTU software this unit comes up as DM device and as the manual states "ignore this" I do and follow the procedure as normal to try set these units up but with no success .

 

this is the first time I am having these problems with the xbees as I have set up a few atleast 10 of them before with  the method in the manual , but now it doesnt work I get timed out in the APM  planner and also it doesnt seem like the Tx and Rx light on APM is initiating and sending to the xbee ,

 

I havent been able to update to the 1161 firmware as it is impossiable to load and find it! so just trying test on the trusted 1002

 

my question is did the APM firmware change ? because all my units dont work!

 

any help would be great

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Distributor

    Hi Johann,

     

    Have you done the loop back check using the X-CTU to make sure they are working? Is it a duff batch of Bee's?

     

    Which code are you running on the APM? Have you tried to roll the code back to an older x.xxV to see if they then work ok?

     

    Which APM Boards are you using, 1280 or 2560?

     

    Regards

     

    Martin.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
15 hours ago
DIY Robocars via Twitter
15 hours ago
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…