YAW problem after 30-40 seconds of flying.

When takeoff in stabilized mode every thing is going smooth. After hovering very steady for 30-40 seconds it start to right yaw about 90 degree. When i try to yaw with my stick opposite direction it have no effect at all and i have to land.

I also tried to disconnect GPS without success. Same same...

I have seen several issues regarding this but treads are of older date and mostly solved on updates. So i post my problem as a new post.

Here are my configuration.

Frame: Talon 550 carbon frame (distance between motors is 42 cm)
Motors: T-Motor 2212-16 750 kv
Props: 8x5
ESC: Turnigy 6Ah
Battery: 3cells, 11,1v 3700mAh

APM 2.5 with 2.8.1 firmware
MP 1.2.29

p=0,2050
i=0,6540
d=0,008

TX: Futaba T8J
RX: Futaba R2008 SB

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • There is an update for the PPM Encoder specifically for Futaba RX's, I don't know if the HK6s is affected or not. Normally you would see motor twitches but it depends what channel assignments you have, either way you shouldn't loose control of yaw for more than a fraction of a second but its probably worth doing the update to see if by chance it does solve the problem

    See http://code.google.com/p/ardupilot-mega/wiki/APM2Encoder

  • Now i'm really confused...

    After "erase" and still got the same problem i changed TX&RX to HK6S (fhhs) i experienced exactly the same !!???

    So i think it could be the ESC's which is not really in right dimension, but they never get warm after that short flight time anyway. I have off course calibrated them with programcard. Refuse to change coz a lot of solder work.
    How can i diagnose this upon my logs??

    Just hooked on Mavlink Message Debug in MP at Configuration/Planner page.

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…