Just upgraded my F450 from APM 2.6 to Pixhawk (lite). Installed 3.4.4.

Amazing software except one thing:

The yaw rate now is very slow: It needs almost 3-4 seconds to turn 360° with full rudder ! (1900 or 1100 pwm) (tested in Stabilize and AltHold). Pitch and roll are pretty responsive.

Radio calibration in MissionPlanner shows that 1900 pwm are recognized.

I have set ACRO_YAW_P from 4.5 to 10 - no visible change

Tried 100-400 for MOT_YAW_HEADROOM -  no visible change

ACRO_Y_EXPO is 0.2

With APM 2.6 and arducopter 3.2.1 i could have 360° turns in less than a second.

Can anyone help me ?

added my param-file

Views: 252


Reply to This

Replies to This Discussion

I have same problem and have no idea what the deal is, have played with parameters and autotune and no luck

I solved this problem myself: Had to set  ATC_RATE_FF_ENAB to 1

Thank You fs007 for posting your solution!  It alsow worked for me on an Y6b with arducopter 3.4.6.  You made my day since my copter would not arm after winter break ("Inconsistent accelerometer").  It never had that problem before.

After full calibration it would start but only land updside down - no way of controlling this beast.  Then I did a firmware update to 3.4.6 and recalibrated everything.  Finally it did fly but not yaw.  Until I found your post.  Then everything worked perfect and I flew for about 1 hour.

Reply to Discussion


© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service