Can't read data from BBBmini with APM planner 2.0.

Hi all,

I am using BBBmini ( as a controller for my Quadcopter. I am currently facing some issues in reading data from Beaglebone through telemetry. 

Telemetry works PERFECTLY(Solid green LED + Red LED blinking while transceiving). It pairs nicely. Please check the below attachment (image file).

Even I can read configuration settings from the remote telemetry

But, it can't read data from Beaglebone. The APM planner 2.0 remains idle even after telemetry configuration and proper connection.

I checked sensors through ssh. It works fine.

I checked the wiring connections. Even I tried swapping the Rx-Tx pins.Still, the problem persists both in windows and Ubuntu

Is there any driver required to be installed on BBB?. I hope additional drivers are not required.

I didn't use CANBUS IC. I checked the schematic. I think CAN bus is not required for telemetry data transmission.

Need help. I Can't figure out the problem. 


Telemetry module: V2 Dual TTL 433Mhz 3DR Radio 433 Telemetry Kit

Similar Problems:



Thanks Everyone.

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


  • Resolved the problem.

    I made a simple mistake. I used a wrong serial port name for telemetry while enabling automatic bootup.The correct form would be

    sudo ./arducopter-quad -B /dev/ttyO5 -C /dev/ttyO4


  • Vinicius Juvinski said:

    What is the command line options are you using?
    Thank you for the reply. I am using APM planner 2.0. So, No command line options. I tried MAVproxy. It returns link 1 down. Is there any Command line options available?. Please let know if i missed any steps. Because i am not aware of using  command line options in BBBmini.
  • What is the command line options are you using?
This reply was deleted.