APM Planner 2.0.10 release


[NOTE: There is a problem with autoupdate in APM Planner 2.0.9 (previous) to this release, users needs to manually update to this release from ]

Some highlights of items new in this release

  • AUTO TUNE support for APM:Plane
  • New Primary Flight Display
  • Google Maps Support fixed
  • Linux Auto Update added
  • TLOG replay (requires a fix :( sorry)
  • Graphing improvements
  • APM:Plane support for channel reversal and Elevons

 see here for downloads

E-mail me when people leave their comments –

You need to be a member of diydrones to add comments!

Join diydrones


  • There is now a 14.04LTS release available here:

    And will be available in every daily release after that (as well as stable). ubuntu/ubuntu64 is for 13.04(raring), and ubuntu_trusty/ubuntu_trusty64 is for 14.04 (trusty).

  • Developer

    or see for another workaround.

    We are working on building 14.04LTS with new releases. We should have a solution soon.

  • @Kenneth, sorry I only just got around to looking into this. I have both libopenscenegraph80 and libopenscenegraph99 packages installed on my ubuntu 14.04 . Looking in launchpad I see that the standard repositories do not have the "80" version. So I must have installed it from a PPA or manually. I'll try and figure out where I got it from. This probably means that everyone who tries to install apmplanner2 on a fresh ubuntu install has the same problem as you.

    libopenscenegraph80 : amd64 : Trusty (14.04) : Ubuntu
  • You could also just modify the dependencies in the .deb and see if it works with the new scenegraph library:

  • I don't think I had any issuesinstalling on 14.04... I'll be at that machine this evening and I'll check what versions of scenegraph etc I have installed and hopefully be able to tell you something helpful.

  • @Aaron, true, but clicking on this deb file it is looking for an older version of libopenscenegraph80. A window opens with instructions to use sudo dpkg -i apmplanner-XXX.deb in termial to load the software.

    @Bill, I tried that earlier, The problem is that the dependency is an older version than what kubuntu 14.04 is currently using.

    This is what I receive when running the command sudo apt-get install libopenscenegraph-dev libssl-dev libqt4-opengl-dev libudev-dev

    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libqt4-opengl-dev is already the newest version.
    libopenscenegraph-dev is already the newest version.
    libssl-dev is already the newest version.
    libudev-dev is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

  • By default Kubuntu uses QApt which is a QT-based app similar to gdebi. Just click on a .deb and you get a lovely install interface.

  • Is there an equivalent to gdebi for KDE? This is a graphical DEB installer for gnome that Domes with Debian and ubuntu. Very handy for people unfammilair with the shell.
  • Developer

    You may find some help here

    check the dependencies part for linux

This reply was deleted.