Latest version of Arduino IDE compatible with Ardupilot code?

Hi all,

I know that there were some issues using Arduino IDE ver 15 and it was recommended to use ver 13.

However, I thought that I read somewhere on the ArduPilot Home page that ver 15 had been fixed and would work with the ArduPilot code.

Can anyone tell me which version will work with the ArduPilot code?

Regards,
TCIII

Views: 267


Developer
Comment by Jordi Muñoz on May 21, 2009 at 8:10pm
Hello 2.1 and up is ONLY compatible with Arduino 15. Ardupilot 2.0 is only compatible with arduino 13 and down.

Admin
Comment by Thomas J Coyle III on May 21, 2009 at 8:18pm
Hi Jordi,

Thanks for the info. Much appreciated.

I assume that Ardupilot 1.0, like Ardupilot 2.0, will only work with Arduino ver 13 and below?

Regards,
TCIII

Developer
Comment by Jordi Muñoz on May 21, 2009 at 8:26pm
Yes that is correct. You are welcome!
Comment by D on May 21, 2009 at 8:38pm
Do I need to use Arduino 13 to load the NE pgm to verify GPS operation, then use 15 for the latest software?

3D Robotics
Comment by Chris Anderson on May 22, 2009 at 7:40am
Just a FYI: We're planning to modify the NE program and ArduPilot 1.0 to support Arduino 15 and up. Stay tuned...

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service