Arducopter 2.8.1 is now in the mission planner and in the downloads area! Remember to do your MP configuration again after loading this code, since it erases your EEPROM and sets it to the new defaults. 

Note: Issues with APM1 user's level feature not working are now resolved.  If you installed 2.8 we highly recommend you upgrade to 2.8.1 as 430 extra bytes of RAM have been freed up which reduces the chance of memory corruption (although we haven't seen any cases of this on the APM2 at least) .

Note #2: this release has not gone out for Traditional Helicopters until they can be tested fully.  Flip and Toy mode have also not been fully tested.

Improvements over 2.7.3:

  • Improved ACRO mode (Leonard Hall)
  • Improved stability patch to reduce "climb-on-yaw" problem (Leonard, Rob Lefebvre, Randy)
  • Rate controller targets moved to body frames (yaw control now works properly when copter is inverted) (Leonard/Randy)
  • Less bouncy Stabilize yaw control (Leonard)
  • OpticalFlow sensor support for APM2.5 (Randy)
  • DMP works again by adding "#define DMP_ENABLED ENABLED" to APM_Config.h You can also log DMP vs DCM to the dataflash by adding "#define SECONDARY_DMP_ENABLED ENABLED" (Randy)
  • Watch dog added to shutdown motors if main loop feezes for 2 seconds (Randy)
  • Thrust curve added to linearize pwm->thrust. Removes deadzone found above 90% throttle in most ESC/motors (Randy)
  • More timing improvements (main loop is now tied to MPU6000s interrupt) (Randy)
  • GPS NMEA bug fix (Alexey Kozin)
  • Logging improvements (log I terms, dump all settings at head of dataflash log) (Jason)

 

Bug Fixes / Parameter changes:

  • fixed skipping of last waypoint (Jason)
  • resolved twitching when no GPS attached (Tridge)
  • fixed loss of altitude if alt hold is engaged before first GPS lock (Randy/Jason)
  • moved Roll-Pitch I terms from Stabilize controllers to Rate controllers
  • TILT_COMPENSATION param tuned for TradHeli (Rob)


Code Cleanup:

  • HAL changes for platform portability (Pat Hickey)
  • Removed INSTANT_PWM (Randy)


As per usual PIDs are optimised for the 3DR/jDrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

Please note that on this release we've moved the Roll and Pitch I terms from the Stabilize controller to the Rate controller. There's some evidence that says this can lead to flips on take-off if you move the roll or pitch sticks around as you take-off so we recommend you leave these sticks in the middle until you're in the air.

Please feel free to report issues you find in the discussion below and/or add them to the issues list.

Thanks and enjoy!

Tags: ACM, APM1, APM2, ArduCopter, Heli, Quad

Views: 111817

Reply to This

Replies to This Discussion

Heino,

What do you mean by "flaky" ?

Maybe USB port problems on your PC ?

I also had the "Failed to level : ac2 2.0.37+ is required." message, but my USB connecter was half pulled out of the PC, I had a battery connected too, and one motor spinned up, pulling the quad, and USB cable.

Reconnected, WITHOUT the battery, all ok :-)

Back in about 3 hrs time.....

Heina,

     Of course you're using an APM1 with a 2560?

Yes 2560. Other flaky behavior - raw sensor output seems to not output at times in the MP. I use this to check the gyros and accel. Radio output seems to work ok. The cli worked on 2 of my 3 scratch reloads and wouldn't run in the third reload as I indicated earlier.

I'll try this morning on my spare apm1 on the bench and see if it is less flaky for me.
my telemetry is using Xbees and it seems to basically work ok between USB and wireless.
Going back to 2.7.3 shows none of the issues.

Hi Heino, it doesn't really help your problem, but just so you know, I did use 2.7.4Zeta with an APM1.4 and didn't notice the problem.

That being said, I didn't actually go through a setup, so I had no need to do an auto level or try CLI.  I always just push my param file back into it after a parameter reset.

However, I couldn't get telemetry to work with the new code.  It would connect to MP with a USB cable, but not 3DR Radio.

Hmmm... I just tried level on this board, I get the same error.   "Failed to level : ac2 2.0.37+ is required."

 

The CLI is also a little bit flaky.  Not as bad as yours.  But I had trouble downloading logs using the GUI, but now they're coming in fine using the CLI log dump.

Ditto! I was using 2.7.1+ Mission Planner 1.2.13  with my APM 1 on a quad. Connected as usual using USB without problem,erased EEPROM x3 times to be certain,reset.

Then went into Firmware and clicked on quad v2.8 all went as per usual and completed upload as had been done several times before. I then clicked on connect to go into  setup,timed out, no heartbeat.Tried several times, again same result. Attempted Mavlink connection via Xbee,same result as USB. Both working perfectly before update to v2.8  Anyone got any clues? 

Spooky! Right time of year anyway.Despondently twiddling about in Mission Planner and,though not connected to APM,clicked on firmware > load v2.8 quad,the usual run-through load & check completed. Grasping at straws, thought I'd give connect one last try before switching off and getting the  bottle out,ultra freaking hell,it worked!!! That was on USB so I tried via Xbee, you could have knocked me down with an undernourished minnow when that also connected.The bloody gremlins must be having a jamboree here.

Hmmm.... I had trouble connecting APM1.4 via 3DR Radio during the beta testing phase.  USB was fine, but no telemetry.  I was told the issue was fixed.  I haven't tested it yet with 2.8.

I think APM1 people are going to have to be patient until this is sorted out.  You can actually load old firmware versions, if you look down on the bottom right of the Firmware page, you'll see a "Load Old" or something like that.  The top of the list should be 2.7.2 last time I checked.

So please, *report* your problems, so we know what we're looking for, but please be patient while we figure it out.

Where do you find the prior versions?  It is somewhat scary to think I can brick my copter with a bad update.  Got me to thinking, should I buy a second Dataflash card from 3DR so that I can always have the prior version ready to reinsert into the APM2?

The firmware is on the AVR processor itself, so you'd have to swap the entire APM. If you do "brick" the APM you can typically fix it with an external programmer.

Heino,

I tested two other APM1 2560's.

First one couldn't level out of MP, but CLI works fine.

Second one leveled out of MP first time.

Tried the first one again, still no luck out of MP, but fine in CLI.

Tried second one out of MP, it failed !!!

But levels fine in CLI.

I then loaded 2.6, it levels fine.

Reloaded 2.8, and it levels Fine !!!!!!!

Did the same with the other APM, hey, it works too!

So it seems to depend on what version of firmware was previously installed.

Edit, the first APM just now DIDN'T want to level after upgrading from 2.6, the only difference between the two is that more reliable one hasn't got a magnetometer fitted.

Oh well, CLI works fine :-)

Any expectation that tuning that worked with previous version would need to be changed to work with the new?

RSS

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service