Arducopter 2.8.1 is now in the mission planner and in the downloads area! Remember to do your MP configuration again after loading this code, since it erases your EEPROM and sets it to the new defaults. 

Note: Issues with APM1 user's level feature not working are now resolved.  If you installed 2.8 we highly recommend you upgrade to 2.8.1 as 430 extra bytes of RAM have been freed up which reduces the chance of memory corruption (although we haven't seen any cases of this on the APM2 at least) .

Note #2: this release has not gone out for Traditional Helicopters until they can be tested fully.  Flip and Toy mode have also not been fully tested.

Improvements over 2.7.3:

  • Improved ACRO mode (Leonard Hall)
  • Improved stability patch to reduce "climb-on-yaw" problem (Leonard, Rob Lefebvre, Randy)
  • Rate controller targets moved to body frames (yaw control now works properly when copter is inverted) (Leonard/Randy)
  • Less bouncy Stabilize yaw control (Leonard)
  • OpticalFlow sensor support for APM2.5 (Randy)
  • DMP works again by adding "#define DMP_ENABLED ENABLED" to APM_Config.h You can also log DMP vs DCM to the dataflash by adding "#define SECONDARY_DMP_ENABLED ENABLED" (Randy)
  • Watch dog added to shutdown motors if main loop feezes for 2 seconds (Randy)
  • Thrust curve added to linearize pwm->thrust. Removes deadzone found above 90% throttle in most ESC/motors (Randy)
  • More timing improvements (main loop is now tied to MPU6000s interrupt) (Randy)
  • GPS NMEA bug fix (Alexey Kozin)
  • Logging improvements (log I terms, dump all settings at head of dataflash log) (Jason)

 

Bug Fixes / Parameter changes:

  • fixed skipping of last waypoint (Jason)
  • resolved twitching when no GPS attached (Tridge)
  • fixed loss of altitude if alt hold is engaged before first GPS lock (Randy/Jason)
  • moved Roll-Pitch I terms from Stabilize controllers to Rate controllers
  • TILT_COMPENSATION param tuned for TradHeli (Rob)


Code Cleanup:

  • HAL changes for platform portability (Pat Hickey)
  • Removed INSTANT_PWM (Randy)


As per usual PIDs are optimised for the 3DR/jDrones quad with 850 motors and 10" props. If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

Please note that on this release we've moved the Roll and Pitch I terms from the Stabilize controller to the Rate controller. There's some evidence that says this can lead to flips on take-off if you move the roll or pitch sticks around as you take-off so we recommend you leave these sticks in the middle until you're in the air.

Please feel free to report issues you find in the discussion below and/or add them to the issues list.

Thanks and enjoy!

Tags: ACM, APM1, APM2, ArduCopter, Heli, Quad

Views: 110255

Reply to This

Replies to This Discussion

The biggest change in the tuning is the move from STB_XXX_I term to RATE_XXX_I terms. If you have already done this then things should work fine. But if you haven't I would start with the default Rate I terms and go from there.


The reason for this is because we are now translating things between the earth and body frame of the copter. This means that many people will have to redo their tune but the rewards are worth it :)

I flew it with no changes at all and it was totally hooked up. I'd already been using rate_****_I instead of stab_****_I however.  

So other than that, shouldn't be a problem.

BIG thank you, Development team & testers have done a great job as usual. I have uploaded to APM 2.5 no problems and will upload to APM 2 later and try and get some testing done tomorrow as weather man says its no raining :-)

I've two Crash at 2.8
first qaid fliped during takeoff - without any lost

then i decrease angular rate p to 0.09 and THR_MAX to 800, checked takeoff - ok

and next fly i try hold it in stabilize & simple mode @ altitude 2m after 10sec hovering quaid make flip. lost 2 props.

its new no tested before frame and maybe some hardware problem

my HW 

morors hextronic dt75

esc hk 30a ubec

frame 550

props gefman 12*4,5

its my log but i fogot to configure motors logging before fly

Attachments:

For people who experience flips on take-off, please try:

   a) reduce your Roll and Pitch Rate P terms from the default 0.175 .. maybe try 0.155.

   b) reduce your Roll and Pitch IMAX terms from the default 5 to 3

 

If this happens to you, we'd very much like to see your dataflash logs and/or tlogs to understand the cause better and figure out a way to avoid it.

I'd suggest even going as low as 1.0.  That's what I've been using.  It won't flip on takeoff even if I try to force it to.

I just wanted to say what we've had here is a great example of the Open Source ethos.  Leonard Hall only joined the dev group just a few weeks ago, and has already stepped up and made a significant contribution to the program.  It's a great example of how anybody who has the skills can jump in, be accepted, and make a difference.

I'm very excited about this release as the changes that have happened to the attitude controller have really made the system much more fun to fly.  It resulted in me "flying the wings off it", litterally. ;)

It also gives us a basis that I'm hoping I can build on to get the helicopter acro mode working better.

Couldn't agree more! Have you all flown the new acro mode? It is truly stunning!

I did a 720 fast pirouette in acro mode in my lounge for the first time, with anything weighing more than a few grams. I'd give the s800 a go at this rate.

Welcome Leonard, it's a pleasure to have you aboard :)

For info, I've tried an apm2 with 2.8 on a vicious X8 (now in bits cause I'm an idiot and have only just really understood failsafe. In case you are wondering, no, it is not good for inside use....) and a f450 frame

Both needed tuning down quite a lot from defaults on rate and stab.  I haven't had any flips but was oscillating in acro and stab, ended up closer to 0.13 and 3.5, strange for me im usually default or slightly higher on the smaller frame. Can't complain though, its flying very very well.  

so many thanks to the team !

works fine and stable.

Christoph Laib

Just tried leveling on 2.8 through the MP on my spare apm1 (sitting on the bench with no GPS or magnetometer) and it displays the same behavior - leveling fails. The CLI level seems to work fine.  It  looks like some kind of interaction between the MP and 2.8.  The light pattern on the APM looks like it is rebooting in the middle of the level operation.  I'm loading 2.7.3 to compare the light behavior when leveling to compare.

Heino, I was talking with Randy and we tested the same thing.  CLI leveling works.  So we can do that for now until we get to the bottom of it.

I also noticed the same thing where the LED's look weird during the GUI level.  My red LED is sort of stuck on dim, which would indicate it's getting an on/off pulse somehow.

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service