Hello guys! Just finished building my first quad, and it is flying!!! 

Now it is time to start tweaking everything to get a even more stable flight.

Two things, my quad can't hold its altitude. I have to constantly change my throttle to keep it more or less at the same height.

I'm flying in a totally windless environment, and the copter won't stay still vertically. How should I tackle this? What settings should a fiddle with to try and fix that? 

Another thing, when I take off, the quad veers to the right, it's not much, but I always have to correct it with the control. How should I try and fix that.

My system consists of a F330 from DJI, with 9x47 blades and 980kv motors, it is flying in the X config and I have a APM v1.4, with no magnetometer. My ESCs are turnigy Plush 18A, flashed with BLHeli firmware.

Other than the takeoff and altitude, the quad is very stable. I'm flying is STABLE mode.

Any help would be very appreciated. Thank you very much!

This community is awesome, couldn't have done without it.

Tags: PID, altitude, takeoff, tuning

Views: 310

Reply to This

Replies to This Discussion

my quad can't hold its altitude. I have to constantly change my throttle to keep it more or less at the same height.

Are you trying to enter Alt Hold or Loiter or are you still in Stabilize? Also, have you looked at your log files to see if there is a bunch of vibrations on your Z axis? If you are in Stabilize mode and having these issues have you messed with any of the PID settings? 

As you can see there are a lot of unknowns here. Have you gone through the setup here? AC Manuel 

Let us know a little more about what you are trying to accomplish and we can point you in the right direction or get you all fixed up!

Hi Claudio. It is normal to adjust throttle permanently when you are using stabilize mode. You need to use Alt-Hold mode to get altitude stabilisation.

Be carefull, the APM 1.4 do not have the same barometric performance as the APM 2.5. So you will not get the altitude stabilisation of the APM 2.5.

If your quad is not staying level when RC sticks are in their center, then you certainly have an accelerometer or radio calibration  problem. Be sure to start the accelerometer calibration procedure on a perfectly level surface and after calibration check from Mission Planner that the HUD is perfectly level.

You must check your ESC calibration as well. Each ESC must have the same calibration.

Radio and accelerometer calibration are mandatory. With coming firmware version 3.0 you will not be able to arm without all calibrations done.

http://copter.ardupilot.com/wiki/configuration/

Olivier

Tom and Olivier, thanks for the replys.

Tom, I'm still in Stabilize mode. I'll log the acc values and check them, I'll post them here later. I did try to add some vibration damping to APM, but maybe is not enough, or I need to add some weight to it. My PID values are all stock.

Olivier, I did the acc, ESC and radio calibrations, but maybe something went less than perfect. I'll do them again. One thing, all my motors start at the same time, at least that's what I think just by looking.

When you say radio calibration, you mean the calibration we do on mission planer? Moving all sticks to max and min positions.

I did the ESC calibration all at once, I'll try doing one at a time.

I really appreciate all the help, I'll report here later.

Thanks!

Claudio

This makes more sense! The stock PIDs will just get you airborne. You will need to set them up for your particular aircraft. run through the setup (link that I gave) and it will get you closer to where you want to be (stable flight with no jumping around). Depending on your setup you might have to adjust the settings a lot, or just a little to obtain what you want. For me and my setup I had to change the settings a LOT, but this is because I have some pretty powerful motors and not a lot of weight. 

It sounds like you got the ESC's set correctly, but if there is ever a doubt do the calibration again. 

Also, it sounds like you did the radio calibration correctly as well. If you moved the sticks to their end travel and have not moved the limits in the radio you should be good on this point.

I think that for the most part all you need to do is get the PIDs set correctly for Stable flight. Once you get these set to your liking you can move on to the other flight modes. Make sure that you check your logs often for vibes and correct those ASAP. If you have any questions on how to set PIDs you can read the link that I gave, or you can youtube how others did theirs. 

Your off to a good start if you can hover without changing anything! Keep flying and try not to crash! :)

Tom, I just did a test flight logging my RAW data. My z-axis values look quite good, I think.

From 6053 samples, 43% are within -10 (from -10.00 to -10.99), 48% are within -9 (from -9.00 to -9.99), 3% are within -8  (from -8.00 to -8.99), 5 samples within -7, 16 samples within -12 and 3 samples within -13.

I read that +-5 is still ok for the APM software to handle, but also that the lower the better.

Are my number as good as I think they are, or I can still improve on them?

RSS

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service