$100 to the person who solves this.

I posted this a few days ago. 




I am getting a little desperate here. 


This application is for US/Mexico Border security.  We have a sensor system in place and the hexacopter is launched on alert,  with 2.8.1 we were flying great.  We upgraded to 2.9.1b and we can't fly auto and it is killing our progress because we are stuck on this darn problem.


I have a background in UAV development specializing in PID tuning so while I am new to the Arducopter APM I am not new to the field.  This problem is making me crazy and I need some new eyes to look at it.


This is a real offer.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I actually just did that. Then we crashed into the shop and lost a LiPo
  • T3
    Also, when all else fails format C. LOL. With regards to the APM, Reset, erase and reload firmware. Be sure to save your parameters and when you reload, use compare and be selective on what parameters you reload. Might not hurt to recalibrate everything while you're at it, radio, ESCs.
  • I am leaning that way rapidly. I just want to be on the same page as everybody else.
  • T3
    If 2.8.1 worked why not use it?
  • Nope, that's not the problem. I can repeat the above probl inside or outside. It screws up in auto and after being in auto.
  • If you switch to Auto does the quad turn in to a certain heading?

    If yes read this

    The mysterious AltHold problem .... solved

  • Below are the logs

    Here was the test.

    1. launch manual - Stabilize
    2. Switch to Atlitude hold (Functioned perfect (with sonar))
    3. Stabilize
    4. Altitude hold - same results
    5. Stabilize
    6. AUTO- immediate decend
    7. Stabilize
    8. Altitude hold - Rapid ascend
    9. Stabilize - landed copter.


    This is very repeatable.  If I go into AUTO mode, altitude hold tries to put the copter into orbit.


    Any clues here?

    2013-05-15 14-47 1.kmz

    2013-05-15 14-47 1.log

    2013-05-15 14-47 1.log.gpx

  • Here are some flight logs.  speed of aircraft was 7 on this flight but has never been a problem before, 


    In this test I manually launched and turned it over to the APM.  The craft flew west descending rapidly.  I then took it back and tried to figure out what direction it was facing as th KML file shows.



  • This is what happens when a Hexacopter attacks your arm.  This happened this morning!


  • Just a thought,

    You said it flies well in stabilize and alt hold so I have to presume you are trying to fly at least to test this at approximately the same speed you would be flying in auto.

    If flying in alt hold is holding the altitude when you try to fly manually at approximately inter-waypoint speed, I don't think that the speed of air movement can be the problem. (If it does descend, then local air movement is the problem).

    Assuming it isn't, is it possible that some how your actual waypoint altitude is not set correctly or at least, as you expect.

    There is also a waypoint option bitmask that among other things allows altitude to be set relative or absolute, I think it defaults to realtive which is OK but if it is set to absolute that could be a problem.

This reply was deleted.


Liam left a comment on Agricultural UAVs
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29