Hi Guys,

I have had my 433mhz radios working in the past (once) and have not used them. Recently I decided to start using them now that I have a nice stable quadcopter. 

Unfortunately I'm having a problem getting the Mission Planner to connect. 

I have two solid green lights. The radios are coming up in the Mission Planner >3Dr Radio > 'Load Settings' - I can see both radios and have hit 'Save Settings'.

When I click 'connect' it just counts down and times out. I have the baud rate set at 57600.

My config:

- Windows 7 Operating System

- Driver is OK in the Device Manager

- Mission Planner 1.2.51 Mav 1.0

The things I have tried:

- Updated firmware on both devices (using Mission Planner and also 3DR Radio Config Software)

- Run the devices on the 3DR Radio Config software - I can see them working under the RSSI menu option

- I have tried to use the radios on my laptop and home PC (both Windows 7)

- I am clicking on the right COM port

The interesting thing is Mission Planner can see the radios and the radios are connected (solid green light). 

I have not changes any settings for the radios (the settings that are applied by the 'Load Settings' button is what I have stuck with). 

I cannot locate someone with the same problem as me.

I hope that someone can assist me. I would really appreciate any help you can provide. 

Thanks in advance. 


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Did you find a solution? I'm having the same problem.
This reply was deleted.


David Hori liked Isabella Domi's profile
Jan 12