I hope someone will know the answer because i don't where i have to search :-) anymore..

A few days ago (4/04/2013) I had a nice flight with my tricopter. It was windy (16 knots - gust 26 knots). No problem for loiter,  RTL and autolanding ! ! I decide to try a short mission. Near the first point, my tricopter didn't find the waypoint (maybe to much wind), and flipt !! Crashed ! See log (2013-04-04 20-49 8)

Th servo was down, but i didn't saw anything else

Today, i went on the field for a new flight. 3DR fixed (9 satellites), stabilize ok, alt lock ok, loiter mode don't work , drift and crash !

In the afternoon, i try again, gps locked (again 9 staellites), stabilize and alt lock ok but nothing for the loiter mode and RTL ! (check second log 2013-04-07 17-12 21)

It looks like my gsp is not working but i have a solid blue light on the apm 2.5.+ 3D fix on my artificial horizon !! Should my gps be broken after the first crash ? I don't believe it's possible..

I'm using the mission planner 1.2.41 and the version 2.9.1b for the firmware on my apm 2.5.

GPS 3DR LEA6 v1.1

Thx  for your help...

Views: 2076


Reply to This

Replies to This Discussion

In your first flight, your motor outputs are running pretty high, and your motor 2 output saturated right at the start of the flip.  To me, this suggests that your battery got too low and wasn't able to provide enough power to the motors to maintain control.

In your second log, it looks like your copter flipped right after you put it in Loiter mode, but I don't really see why.  Your pitchIn changes rapidly, and your motors are being commanded between min and max values.  You were only in loiter mode for a few seconds, and I never see a change to RTL.

For the first flight, it was a lot of wind (16-26 knots). The tricopter flow (very well) in a straight line to go the 1st waypoint. The wind was not on the face. To make a correction, it has to put one motor lower in the wind. That's why one motor had more rpm than the other one...

In the second log, i had already crashed twice and don't try the rtl mode anymore in these log.

yes, i was in loiter mode a few seconds because i saw the tricopter didn't use the gps. I have tried a few times but never had a gps in loiter mode. he flips a few times too in loiter mode.

I'm sure he doesn't have any signal! I don't understand, the blue led is solid on the apm and i have a gps fix on the mission planner. 

Where do i have to seach? It's strange that i didn't had problem for the first flight till the crash..

Should it be a problem with the cable? Gps broken? bad parameter on the apm?

The blue led on the gps is flashing but i saw in the forum that it should be normal..

Thx for you for your answer !

That were the first flights today with the loiter/rtl crash

it can maybe help someone to find the problem :-)



patrick kijk hier....


Hi guys,

Has anyone of you encountered the following?

I bought a ublox neo (the $27 version) and connected it up to the APM2.5

at first everything seemed ok (connected to USB )  data was coming in from the GPS and the APM said ublox ok.

But then I disconnected the APM from usb and hooked it up to the battery. 

GPS lost (NO GPS!) ...back to USB and there was the GPS again.


(kind of) ....my USB voltage is 4.5V the output data of the GPS has an amplitude of 2.5V . When on USB, the APM finds 2.5V worthy of a "1". When on 5 Volts (via lm7805 from battery) the APM DOESN'T find 2.5V a logical "1" voltage, so the GPS connection is lost......I am building a level converter for TX data out from GPS. 

Thx for your answer but how do you explain that i have a solid blue led when i put the battery ? if you look to my logs, you can see the gps find 9 satellites ...

The first time i did a try with the gps, i didn't had any problems and could see how the loiter, RTL and auto landing modes did it great.

Since the last good flight (with a lot of wind where the tricopter could find the waypoint and flips down) my tricopter become crazy when i'm trying to use the loiter of RTL mode ??????????

I beleive it's something else you are saying ..No?


Problem solved !!!!!!!!!

I found the problem and could fly the mission in attachment without any problem!

I made 3 corrections :

  • the red wire of the cable between the apm and 3D GPS could move in the connector ( 1/10 of a mm) I put glue on it to be sure the cable could not move anymore
  • I enable the automatic learning mode for the compas
  • i enable the gps lock check before arming the apm

I think the problem/ failure was coming from the red wire who could move a little bit in the connector...

I'm happy ! now my tricopter is flying very well !!!!!

Thx for your help !


Thanks for posting back to say what the solution was. Directed me straight to the problem on mine. I swapped the gps cable despite nothing obviously at fault with the old one I was using. Works as it should now, brilliant. Mine too showed satalites and the OSD home arrow and distance seemed to work fine but it wouldn't loiter at all, it would jut shoot off and I would have to quickly flick back to manual. All fixed and all good now, thanks again for sharing.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service