3DR Radio stuck in bootloader mode

I'm really hoping somebody can help me out here.

I just got a set of 3DR Radios, the older style where the air unit has 5 pins and the ground unit has the huge antenna. It came with 1.7 sik on both so I proceeded to update the SiK on them.

Ground unit went fine.

Air unit, not so good.

I have updated dozens of radios using both mission planner or 3DR Radio Config and this is a new issue for me.

I selected the com port for the radio, it went through its erasing, uploading, verifying, and said success but instead of it going back to a green blinky light it went back to a solid bright red light.

I am able to flash it over and over and each time it goes through just fine ending with a success message but each time it goes back to the bright red light.

2014-11-22 05:11:59,531 DEBUG MissionPlanner._3DRradio - multi 54825/66

(:0) [1]
2014-11-22 05:11:59,544 DEBUG MissionPlanner._3DRradio - verf 0xF7FE/2
(:0) [1]
2014-11-22 05:11:59,545 DEBUG MissionPlanner._3DRradio - multi 0/2
(:0) [1]
2014-11-22 05:11:59,546 INFO MissionPlanner._3DRradio - Success
(:0) [1]

is the end of the log.

What can I do to get it out of bootloader mode and back to accepting normal operations?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ok now it gets weird. I originally tried on 2 different FTDI adapters and it did the same on each. Today I tried a different one but it seems it won't talk to the bootloader. But that's ok because it seems the issue was voltage. Looks like though both the original adapters I used SAID they were 5v the are not. They are 3.3v. As soon as I plugged it into the other FTDI adapter which is 5v the light went blinky green and now works perfectly.

    So it seems it didn't get enough volts when finishing the firmware update to switch back to normal mode but as soon as it DID get enough volts. poof working like a charm.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25