Wiki Ninja

I'm trying to get the 3DR telemerty radios configured for the 1st time.

But I can't get the radios talking to each other.

My situation:

2.5 APM with latest firmware

APM powered via PSB & ESC, APM LED's red = flashing, blue = on, GPS/red = on

MP set to Com12, 57600 baud

3DR home/usb radio with latest firmware, radio flashed red & green during update

Win 7 x64 Device Manager shows driver installed correctly per FTDI installation/troubleshooting .pdf (see attached)

However, when I use 3DRRadio config 0.9 application > Terminal > ATI = no response from the home/usb radio.... no response from the radio with other AT commands

3DR home/usb radio flashes green

3DR remote radio flashes alternate green & red

Ctrl+A radio configuration displays home/usb radio default config (save worked ok)

no config values display from the remote radio

When I try to 'Connect' I get the countdoun screen which when it reaches 0, it locks up MP, The only way to exit is to Windoes > Task Manager > end task

What does 'Copy required items to remote" do? when do I use this button?

What's my next troubleshooting step to get the radios talking to one another?

04-Oct-12 11-44-33 AM.png

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Follow the steps below for Linux/Ubuntu to configure Telemetry radio settings (almost all today use SIK firmware):

    1) Install Putty (sudo apt-get install putty)

    2) Insert the telemetry device to PC over USB

    3) Open Putty and configure (look under Session and Connection->Serial sections) :

    Baud rate/Speed: 57600

    Serial port/line: /dev/ttyUSB0 (check using ls /dev/tty* on terminal)

    Data bits: 8 

    Stop bits: 1

    Parity: None

    Flow control: XON/XOFF

    4) Click Open button

    5) An empty serial terminal is shown

    6) Type +++ on terminal and press enter

    7) You would see "OK"

    8) Type ATI5 to show all user settable EEPROM parameters

    Perhaps the most useful command is ‘ATI5’ which displays all user settable EEPROM parameters. That will produce a report like this:

    3702395784?profile=original

    9) Now test with the following commands:

    The AT commands available are:

    • ATI - show radio version
    • ATI2 - show board type
    • ATI3 - show board frequency
    • ATI4 - show board version
    • ATI5 - show all user settable EEPROM parameters
    • ATI6 - display TDM timing report
    • ATI7 - display RSSI signal report
    • ATO - exit AT command mode
    • ATSn? - display radio parameter number ‘n’
    • ATSn=X - set radio parameter number ‘n’ to ‘X’
    • ATZ - reboot the radio
    • AT&W - write current parameters to EEPROM
    • AT&F - reset all parameters to factory default
    • AT&T=RSSI - enable RSSI debug reporting
    • AT&T=TDM - enable TDM debug reporting
    • AT&T - disable debug reporting

    All of these commands, except for ATO, may be used on a connected remote radio by replacing ‘AT’ with ‘RT’.

    Hope this helps "someone" trying to figure out how this works! Basically its super simple and you can do this over coffee!!

    Cheers,

    Shyam

  • I've read through this thread, ensured all connections are good, but have a bricked 3DR stuck in bootloader mode. 

    I set up my RFD900 in MP (ground radio), no problem. I then switched to the pixhawk com port and connected through to the 3DR air radio (AC 3.3 RC11), loaded the settings from the 3dr air radio in MP, made changes, saved changes.  But, the 3DR radio had an older 1.6 f/w so I decided to update it with MP. 

    I clicked "update firmware (local)", it started the process of erasing eeprom and then loading radio.hex. it then failed with a sync error, and I could not reconnect to it. i kept getting 'cannot identify radio".   the radio has a solid red light on it like its stuck on bootloader mode. i tried the 3DR firmware tool, v0.9.  same error - cannot connect to it and get 'cannot identify radio' error.  my log file is below- essentially the latest version of MP seems to have bricked my 3DR radio, and I completely cannot find a method of forcing a new firmware flash. the 3DR radio just sits there with red light.

    help? 

    2015-09-16 18:24:50,376 DEBUG ArdupilotMega.Utilities.ThemeManager - Theme set to None (:0) [1]
    2015-09-16 18:24:55,492  INFO ArdupilotMega._3DRradio - Connect btr 0 baud 57600 (:0) [1]
    2015-09-16 18:24:55,492  INFO ArdupilotMega._3DRradio - Connect first responce  0 (:0) [1]
    2015-09-16 18:24:55,594  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:24:56,596  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:24:57,098  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:24:57,199  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:24:58,201  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:24:58,702  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:24:58,802  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:24:59,804  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:25:00,306  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:25:00,407  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:25:01,407  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:25:01,909  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:25:01,909  INFO ArdupilotMega._3DRradio - Connect Version:
     (:0) [1]
    2015-09-16 18:25:02,010  INFO ArdupilotMega._3DRradio - Doing Command ATO (:0) [1]
    2015-09-16 18:25:03,012  INFO ArdupilotMega._3DRradio - cmd ATO echo  (:0) [1]
    2015-09-16 18:25:03,512  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:25:03,614  INFO ArdupilotMega._3DRradio - Doing Command ATO (:0) [1]
    2015-09-16 18:25:04,615  INFO ArdupilotMega._3DRradio - cmd ATO echo  (:0) [1]
    2015-09-16 18:25:05,117  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:25:09,823  INFO ArdupilotMega._3DRradio - Trying Bootloader Mode (:0) [1]
    2015-09-16 18:25:18,077  INFO ArdupilotMega._3DRradio - Trying Firmware Mode (:0) [1]
    2015-09-16 18:25:20,282  INFO ArdupilotMega._3DRradio - Connect btr 0 baud 57600 (:0) [1]
    2015-09-16 18:25:20,282  INFO ArdupilotMega._3DRradio - Connect first responce  0 (:0) [1]
    2015-09-16 18:25:20,384  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:25:21,386  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:25:21,888  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:25:21,989  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:25:22,991  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:25:23,491  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:25:23,592  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:25:24,594  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:25:25,095  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:25:25,196  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:25:26,198  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:25:26,698  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:25:26,702  INFO ArdupilotMega._3DRradio - Connect Version:
     (:0) [1]
    2015-09-16 18:31:28,651  INFO ArdupilotMega._3DRradio - Trying Bootloader Mode (:0) [1]
    2015-09-16 18:31:36,906  INFO ArdupilotMega._3DRradio - Trying Firmware Mode (:0) [1]
    2015-09-16 18:31:39,111  INFO ArdupilotMega._3DRradio - Connect btr 0 baud 9600 (:0) [1]
    2015-09-16 18:31:39,111  INFO ArdupilotMega._3DRradio - Connect first responce  0 (:0) [1]
    2015-09-16 18:31:39,212  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:31:40,214  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:31:40,715  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:31:40,815  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:31:41,816  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:31:42,318  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:31:42,418  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:31:43,420  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:31:43,921  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:31:44,022  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:31:45,024  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:31:45,524  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:31:45,524  INFO ArdupilotMega._3DRradio - Connect Version:
     (:0) [1]
    2015-09-16 18:31:53,106  INFO ArdupilotMega._3DRradio - Trying Bootloader Mode (:0) [1]
    2015-09-16 18:32:01,353  INFO ArdupilotMega._3DRradio - Trying Firmware Mode (:0) [1]
    2015-09-16 18:32:03,558  INFO ArdupilotMega._3DRradio - Connect btr 0 baud 28800 (:0) [1]
    2015-09-16 18:32:03,558  INFO ArdupilotMega._3DRradio - Connect first responce  0 (:0) [1]
    2015-09-16 18:32:03,660  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:32:04,661  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:32:05,163  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:32:05,264  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:32:06,266  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:32:06,766  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:32:06,867  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:32:07,869  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:32:08,370  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:32:08,472  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:32:09,474  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:32:09,975  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:32:09,975  INFO ArdupilotMega._3DRradio - Connect Version:
     (:0) [1]
    2015-09-16 18:32:47,789  INFO ArdupilotMega._3DRradio - Trying Bootloader Mode (:0) [1]
    2015-09-16 18:32:56,041  INFO ArdupilotMega._3DRradio - Trying Firmware Mode (:0) [1]
    2015-09-16 18:32:58,245  INFO ArdupilotMega._3DRradio - Connect btr 0 baud 115200 (:0) [1]
    2015-09-16 18:32:58,245  INFO ArdupilotMega._3DRradio - Connect first responce  0 (:0) [1]
    2015-09-16 18:32:58,346  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:32:59,348  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:32:59,848  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:32:59,950  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:33:00,952  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:33:01,452  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:33:01,553  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:33:02,555  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:33:03,055  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:33:03,156  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:33:04,158  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:33:04,659  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:33:04,659  INFO ArdupilotMega._3DRradio - Connect Version:
     (:0) [1]
    2015-09-16 18:33:29,927  INFO ArdupilotMega._3DRradio - Trying Bootloader Mode (:0) [1]
    2015-09-16 18:33:36,194  INFO ArdupilotMega._3DRradio - Trying Firmware Mode (:0) [1]
    2015-09-16 18:33:38,399  INFO ArdupilotMega._3DRradio - Connect btr 0 baud 38400 (:0) [1]
    2015-09-16 18:33:38,399  INFO ArdupilotMega._3DRradio - Connect first responce  0 (:0) [1]
    2015-09-16 18:33:38,500  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:33:39,501  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:33:40,002  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:33:40,103  INFO ArdupilotMega._3DRradio - Doing Command AT&T (:0) [1]
    2015-09-16 18:33:41,105  INFO ArdupilotMega._3DRradio - cmd AT&T echo  (:0) [1]
    2015-09-16 18:33:41,607  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:33:41,708  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:33:42,710  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:33:43,211  INFO ArdupilotMega._3DRradio - responce 0  (:0) [1]
    2015-09-16 18:33:43,312  INFO ArdupilotMega._3DRradio - Doing Command ATI (:0) [1]
    2015-09-16 18:33:44,314  INFO ArdupilotMega._3DRradio - cmd ATI echo  (:0) [1]
    2015-09-16 18:33:44,815  INFO ArdupilotMega._3DRradio - responce 1  (:0) [1]
    2015-09-16 18:33:44,815  INFO ArdupilotMega._3DRradio - Connect Version:
     (:0) [1]

  • this is nice but mom porn is better :D

  • Hi, I have tried the steps you have mentioned but still no improvement, Air radio is not responding and always blinking red and green. what is it indicating ?
    here is the video link

  • @Stephen

    It seems one of your radios is temporarily bricked and you need to flash a new bootloader on to it. I cant recall the exact colors of the LED, but if they are both on they should both be solid green. I think the fact one is alternating between red and green tells us you might need to flash the bootloader for it. If you look around theres a page that tells you how to do this. The procedure involves you shorting two points on the board, and then powering up the radio. Once there you can upload the bootloader and new firmware. 

    I had a similar problem way back and once i did that everything just worked. The annoying part was getting past the first hurdle.

  • Another solution that I found was that despite all my radios showing solid green LEDs, I simply did not have the USB driver for the radio installed in Windows 7. If you're using 64-bit, you'll need to download the driver.

    http://www.ftdichip.com/Drivers/D2XX.htm

This reply was deleted.

Activity

DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…