3dr telemetry not working

Hi guys and gals my name is Rick I have been searching the forums and youtube channels for help to my issue.
I have an Iris+ been trying to set my 3dr telemetry up for a month, first my issue was my LTE 7" max phone wasn't OTG compatible so I ordered a Nexus 7 phone, well the planner would say connected even thoe it wasn't and droid planner would say connection lost, so I ordered a bluetooth with no better luck. I downloaded drivers to my windows 8.1 computer and still wouldn't connect. I went into missin planner under initial setup and rest all the 3dr radio defult. my telemetry still won't connect. anything else I should try? Here is a copy of the youtube linck I uploaded two nights ago before trying ther desktop and default settings.


Thanks in advance.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey guys, got my new 3dr telemetry in and connected they work great solved all my problems. My guess is one of the others were bad. my iris is up and running great from my ground station. I use mission planner on my nexus with a mini usb to usb connector. Thanks for the help and ideas. I hope this helps someone else who may be having issues in the future.


  • When I first got my Iris + I had a similar problem.  I used mission planner/APM Planner for the mac(Windows would also work) and figured it out.  Not sure it is the same problem but here is what I found.

    The telemetry modules have Net IDs assigned to them (default ID is 25) and the two of them(one in the iris and the one connected to mission planner or droid planner have to have the same ID)

    I connected one of the modules to the computer and checked the Net ID through mission planner (initial setup --> 3drRadio)

    link to the setup instructions http://copter.ardupilot.com/wiki/common-optional-hardware/common-te...

    I then took the other module out of the iris and did the same thing making sure they had the same Net ID.  after confirming they both worked and had the same Net ID I put it back into the iris and connecting the other one to the computer and they connected.

    It is not common for the IDs to be different as they are all set to 25 by default but it is worth checking out.  Also, it is possible one of the modules is bad. by checking both of them as shown above you should be able to determine this.

    hope this helps.

    • Yeah I rest that last night myself I even changed the numbers alittle. when I was done I reset defalts on both. Nothing worked. I am starting to think that one is bad, but afeter the $$ i have spent just to get it setup i would hate to buy another module to find out it wasn't the issue. thanks for the reply

      • here are a few more videosof things i tried tonight, all with no luck, something went wrong after the videos my serial port shorted out to my ground module. So i ordered another set of radios off ebay. I hope these videos helps someone else. I was almost like the telem 1 (pixhawk) was resetting my radio. I will repost what happens when i get my new radios in a few days.
        https://youtu.be/ChkVw9N16b0 sorry for all the background noise on nthis one my mic is stronger than i thought

        • Rick,

          Did you get this IRIS+ new from 3DR? Or new from somewhere else (amazon, B&H,etc)  if so did the telemetry ever work?  The videos are hard to really see what is going on. I do see some of the settings but I am not so sure how you are testing.  It looked like you tested each one separately on mission planner on your computer via USB and it looked like they both worked.  Then you did something else I could not really see or tell what was going on(blue tooth, something else.. not so sure) in any case once you put the module back in the iris and connected it to the pix hawk it did not work?  As I was saying if you did get this Iris + recently new and the telemetry did not work I would open a case with 3DR.  they may be able to see if there is an issue with the telemetry module or if it is the pixhawk or something else.

          • Hi Frank yeah I bought the Iris new from a 3rd party, but 3dr recongnizes it as a new item, they helped me with a firmware issue one i recieved it in the mail, and a gps issue when it flipped on tack off I tried testing the radios together, seprate and the only time I could get the units to pair was when the pixhawk wasn't connected. when the pixhawk was connected it would change the frequency of the second radio. Well while changing the serial connectors so many times one of the pins became bent and shorted out. I have a new radio and transmitter that should be here I believe by friday. I know the telemerty data works on my radio and m OSD. I will lket you all know how it turns out.

This reply was deleted.