I have just bought the ArduPilot Mega 2560 Full Kit... plus the Triple Axis Magnetometer HMC5883L. I should have it built over the weekend.. then i'm off to a my mates machine shop, and i'll make the splitter plate for the lower frame onto which i am going to fit the Ardupilot. the magnetometer i'll put on the tail as suggested. I am going to use my X-cell Razor 600E. For those that dont know its around the 50 size nitro heli.

Do i need to buy any other sensors i.e. the Sonar... i can fly a helicopter all day long but this is my first time flying one with stabilisation so any tips would be gratefully appreciated.

If this works well then i am going to try and use it on my x-cell gasser. i can get up to 20 minute flights with this. But i think for the time being a battery 600 is the way to go.

i'll post some pictures when i have it all together.

 

 

Setup Instructions

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Mike good pick up on the PID Cascading from the ACRO or Rate to Stabilise. I have been trying different numbers on the bench and if you set Rate to zero then not much happens in stabilise mode.

     

    So here's my plan.

    I'm going to get the Heli flying in Rate/Acro (just as a flybarless controller).

    Once i'm happy with the way it flies in that, then i'll start to test the Stabilise mode and try and get some sensible numbers in the PI

    What you think?

     

    Those numbers are fine porto (check the manual)

     

    Note: once i have a decent idea on how the Acro/Rate PI's influence each other i will add a few pointers to the manual.

  • So I finally got around to trying to setup my APM.  Currently I am setting up the radio and this is what I got:

     

    CH1 - 1126 | 1909

    CH2 - 1132 | 1903

    CH3 - 1022 | 1818

    CH4 - 1120 | 1913

    CH5 - 1117 | 1919

    CH6 - 1500 | 1500

    CH7 - 1500 | 1500

    Do these values look OK? These seem to not have much of a spread

     

    A little bit on setup.  I am using a Trex600E.  Scorpion Motor, Hobbyking 70A/80A ESC, Castle BEC - set to 5v, Spektrum AR7000 receiver, Futaba 403 HH tail gyro, JR9303 with Spektrum DSM2 conversion, APM full kit - I hope to add Magnetometer soon.

  • Hi Malcolm, yes your manual is very good! So it sounds like we wont be advised to fly our flybarless machines in manual mode due to there not being any rate compensation? Almost ready to go, just waiting on the engine to arrive, finalizing the camera and apm mount, trying for two levels of vibe isolation for the apm mount :) Wrapping my poor head around all these new concepts!
  • So to get this all correct.

    Acro mode is just a flybarless controller without stabilise?
    If so then that would be my get out if all goes wrong with the stabilise mode.
    Do i set the amount of degrees per second with the PID?

    IMAX Limits the amount of I that i can set in the PID section. in any of the configurations stab, acro etc

    The PID's in acro are still there although they are not automatically filled in.

    Well if nothing else we are getting some good information from this Discussion :)
  • Hi Mickael, yes traditional heli here, raptor 90 gasser if I can keep the APM isolated from the vibes well enough.
  • Tested Helicopter today.
    I have removed the tail control from the APM.
    Spun Helicopter up on the floor and the swash plate shakes have disapperd so it was an issue from the tail PID control.
    Unfortunaetly when i hopped the helicopter in the air, the P settings were too low and although heli was stable i couldn't stop it from moving. Not enough swash plate movement. Had no choice but to close the throttle.

    New Parts Needed.
    Boom, Main shaft, Blades, Gps module, Mag module, Sonar and a set of skids. Yup it came down hard.

    Make sure you have enough P gain movement so you can control the Helicopter, at least enough for normal flight control. With the more heavy 600, you will need a lot more P. My I setting was at zero as randy said.
  • If anyone has found any issues with the manual, could you please give me a shout, so i can change any errors.
  • had the first flight today, was a little shaky, didnt have my lap top with me so couldnt change the pid values.

    But i got 2 feet in the air for all of 5 seconds. Once i get my laptop down the field with me then it'll be better, one good thing the tail was rock solid.

    The flybarless in the controller works fine randy.

     

    If anyone wants me to write a build process, beacuse i know this discussion is all over the place, then just ask...

     

    Thanks to all the guys here on DIYDrones.....:)

    Martin, Chris, Randy top guys:)

  • 3692236726?profile=originalThe finished ArduRazor :)

     

    I put the 450 in so u can get an idea of the size.

     

    I am going to try stabilise and altitude hold, i did the flybarless conversion for £43.00. So thanks to the guy on the other forum for that Info.

     

    malc3692236807?profile=original

  • Finally finished, 

    Few things are a bit different, had to put the mag (compass) Components down pins forward.

    It also didnt want to be mounted anywhere except underneath the battery tray, i think there is a little to much carbon and metal about. Gives great readings where it is.

    Also i couldnt put gps anywhere except on the back of one of the swash servo, it'll be ok until the lead turns up.

    I'm only testing Stabilise tomorrow unless all goes really well then i shall try loiter.

     

    Randy the mission planner seems to have changed the sonar PID have gone and been superseded by Altitude hold PID and loiter PID, i'm guessing i need to set both?

     

    3692236860?profile=original

This reply was deleted.

Activity