AC2_HIL Problem wanted to run the HIL simulator today on my quad and as soon as I tried to take off, this happened. I set up the quad exactly the same way I do when I install the actual AC2 software. Does anyone have any ideas or has anyone seen this before?(video link is above...couldn't embed the video from my iPad.)Thanks in advance.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • For some reason I can't get this to work.

    I have followed the instructions on the wiki. AC is setup and configured. I can get FlightGear to start and see the copter sitting on the runway. As soon as I hit Sim Link Start, the motors start to turn. However, I can't get it to lift off. It seems the control commands are not beeing forwarded. I also don't get any Servo Outputs in APM. Tried ArduPilot and X-Plane which worked fine.

    I would appreciate any hints.



  • Developer

    make sure you program the virtual quad for + mode not X mode

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21