AC3.2.1 APM 2.5 Throttle pulsates in Loiter


I have a problem after updating AC to 3.2.1 from 3.1.5.

When in Loiter, the the speed of the motors rev up and down/pulsate quite rapidly. This was working fine when I was using previous versions of arducopter.

I have downloaded the logs, and have looked into accX, accY and accZ. These seems to be inside the range specified in the wiki at arducopter. (Log_vibrations.bin)

Please have a look at the Log.bin, and note the difference between ThrIn and ThrOut when I'm in Loiter mode.


Anyone having any idea what the problem may be?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


        • Use the Force, Luc! Via Mission Planner, in "Install firmware" section there is "Pick previous firmware" in lower right corner. Then it will give you choice of old releases.

          • Thank you. I'm blind :P

        • Open mission planner and load older firmware, then connect to apm with mavlink and upload new firmware to fc

      • I am trying everything to isolate them. Now flying on moongel dampers. I try to roolback and run autotune.

  • After reading this.  I gave this a try, downgrade from 3.2.1 and 3.1.5 worked for me as well.

    Some details.  I bought a micro APM set from HK recently.  I decided to ripoff my pixhawk clone/hk pilot32 from the existing V550/TBS discovery clone.  After all the re-work, to my disappointment my once locked on V550 turned into a hardly flyable quad when on alt hold and loiter.  After a lot of attempts covering the barometer, PID tuning, etc.  I gave up.  I put back the old flight controller on the V550.

    I then decided to use the micro APM on a new frame a H600 which is a QAV550 clone.  I am pleased to see that the APM flew great.  So I thought the issue on the V550 is the frame and likely the motors not as compatible.  After a few more testing I added payload now to the H600 which increased its AUW from 1.3kg to 1.7kg.  On my first flight to my surprise the problem I had with V550 was showing as well on the H600.  Unable to keep altitude, the motors are pulsating.

    After a few more attempts I am convinced that its the APM is the issue and not the old frame.  I then downgraded to 3.1.5 and after 2 quick flights, it was a lot more stable.

    It seems what happens is that during alt hold and loiter.  The APM would correct, then go back to 50% throttle literally so if your craft requires less than or more than 50% throttle.  The APM will constantly try to correct it self, but its all over the place.

    I will try to do more flight tests and upgrade to 3.2.1 and get the logs.  Is there a bug somewhere that this reported?  Seems on the hk pilot32 everything is fine on 3.2.1, only the APM is suffering.

    • As funny as it is, it can be caused by cheaper IMU sensors on HK clone boards. Without sufficient (and maybe excessive) resolution, board may just not "see" small fluctuations and vibrations, so it doesn't try to compensate. 

      In opposite to that, brand APM board detects not only aircraft orientation changes, but also senses small vibrations caused by motors and airframe rotation motor resonance.

      It's just a theory, but that's the best explanation I have for a moment. 

      In neighbor theme there was mentioning, that with vibration dampening 3.2.1 firmware flies pretty satisfactory.

      • I run 2 x apm2.6 fc's both on vibration isolation platforms, one 3dr one clone, both pulsate throttle in alt hold/loiter. I have just built a 330mm quad using the hk2.7 mini fc and this too pulsates the throttle. Drop back the firmware and all is ok. Recently built a quanum venture H framed quad on latest firmware on 3s it flew with mild pulsing of the thrttle as soon as I tried it on 4s the pulsating was greatly accentuated, assume due to weight or extra thrust range. My hex also does it. So everything I have both genuine, clone quad, hex small, large vibration damped all pulsate the throttle. Its easier for me just to drop the firmware back. Hope this helps

        • Thanks for confirming that original 3dr APM also has the same issue, anyone else with a original 3dr APM having the same issue?

          It's easy to knock off cheap means poor hardware. I actually find the micro APM to be innovative, it's really small. The micro osd and telemetry is also small and works.

          I also saw a thread on the pixhawk an original one suffering from similar issues. My cheap clone hk pilot32 works fine on 3.2 and 3.2.1

          I will check my vibration logs, but my APM sits on a top deck that is isolated by dampening balls. The APM is attached by a thick but sturdy foam tape. It also flies very well on stabilize mode, so I am doubtful it's the IMU. Does stabilize rely solely on the IMU?
  • Installed V3.1.5 again today,

    Result: Loiter, RTL and Althold are again working as they should.

  • Do you guys know if the newest firmware for the APM 2.5-2.6 is still under bug fixing or a development is totally gone and we must stay on 3.1.5 version? Some new features in 3.2+ are very useful.

This reply was deleted.