AC3.2.1 APM 2.5 Throttle pulsates in Loiter


I have a problem after updating AC to 3.2.1 from 3.1.5.

When in Loiter, the the speed of the motors rev up and down/pulsate quite rapidly. This was working fine when I was using previous versions of arducopter.

I have downloaded the logs, and have looked into accX, accY and accZ. These seems to be inside the range specified in the wiki at arducopter. (Log_vibrations.bin)

Please have a look at the Log.bin, and note the difference between ThrIn and ThrOut when I'm in Loiter mode.


Anyone having any idea what the problem may be?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I also have this issue with 3.2.1. Worked fine before with older firmware. I have tried tuning the throttle PID´s but have not had any success with that. Anyone know where to look? is it fixable with tuning or is it a bug in firmware?

    • I honestly tried to make the best of PID tuning, but if "alt hold" had satisfactory results in 3.2.1, then in "loiter" mode it was "blowing the roof of".

      I guess there's and issue in math. EKF likes to do "additive alt increase" bu it was said that in new firmware EKF is not enabled by default.

      Anyway, flying good on 3.1.5

  • well ill be damned....I just posted a new thread on this same similar problem and I just downgraded to 3.1.5 like you guys suggested and its smooth as a baby now, no surges at all....all problems solved!!

  • I had exactly the same issue, but with that difference, that I had 3.2.1 firmware from start.

    After some reading I run into APM forum topic, that was telling about altitude drift.

    Following suggestions I flashed 3.1.5 without changing ANYTHING else.

    Magic! It worked! On top of that I got old console back (without mavlink binaries falling to console) and need to download logs via console, which is tolerable imo.

    Verdict: ArduCopter 3.2.1 need extensive debug and is not ready for release.

  • I have now made a video showing the behavior in Althold, Stabilize and Loiter.

    To me the barometer values looks ok, so I really don't know what is going on..

    Please have a look at my video here.

    • Did you try going back to 3.1.5?
      • No I havent tried that yet. If I do I loose the scaling on RSSI voltage. I currently use FrSky receiver, and it gives out 0-3.3V, and not 0-5V wich is the default in 3.1.5.

  • I have tested firmware version 3.1.5, 3.2 and 3.2.1 in APM 2.5.2 and 2.6 with the same result .

    Version 3.1.5 is best in altitude controlled flights but a little less stable in Stabilize mode.

    Version 3.2 is average between flight performance in Stabilize and Althold mode.

    Version 3.2.1 is best in Stabilize mode but horrible in Althold mode. Displayed altitude fluctuate between -1 to +3m even at ground level. (version 3.1.5 fluctuate between 0-0.2m)

    This firmware in a flight at low altitude bellow 3m also very offen issue a Land command.

    The outside temperature was about 10C in all flights.

  • I am having the same issue with 3.2.1 so I loaded 3.1 and all seems well now.
  • I have the same problem after 3.2.1 update with quadcopter and APM 2.6 in althold and all gps controlled modes. I found that the barometer values are very unstable in newest firmware but Arducopter 3.1.5 version is without any problem.

This reply was deleted.