I have a problem with my APM2 with the calibration of accelerometers use the M.P. 1.2.67, and when I do the calibration, as wiki procedures, it gives me the following error "Calibration Failed", I run both in MP mode in the CLI.
What might be the APM2 defective?

APM2 fw 3.0.1

MP 1.2.67

I hope this is the right thread!!!!!!


Views: 3806

Reply to This

Replies to This Discussion

Hello, you have the Z Acc offset too high for the calibration to take place correctly (limits are 3.5 and you have 4.09)

While it is not a big deal, I would consider a RMA, in fact this is probably due to a misplacement of the MPU6000, or a bad soldering, or worse a defective mpu6000 unit.

If you don't want to wait you can try and compile the code yourself and put a higher limit in the 

libraries/AP_InertialSensor/AP_InertialSensor.cpp file at line (circa) 480.

This is the code you have to modify:

// sanity check offsets (3.5 is roughly 3/10th of a G, 5.0 is roughly half a G)
if( accel_offsets.is_nan() || fabsf(accel_offsets.x) > 3.5f || fabsf(accel_offsets.y) > 3.5f || fabsf(accel_offsets.z) > 4.1f ) {
success = false;


Hello Emile,

Thanks for the response and the council to open an RMA, he'll try to change the code to see if it passes the setup.



Just to note, for some reason while i was trying to calibrate the Accel via the Wireless Radio so that not to have cables in the way, it was failing everytime... 

Once I connected via wire/usb and calibrated via the CLI, it worked.

I solved my problem by disableing imu2
As it shown strange readings , I thing it was damaged so I enabled only imu 1 and it worked
See this

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service