Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thank you for your answers! You might be correct, but I find the confusion between id 1 and 34 both in the ArduPilot code and in the MissonPlanner code. Both the .h file and the c# file are generated from the same XML-file.

    When I included the same .h file in MinimOSD I got some errors because some of the variables could not be found in the .h file from ArduPilot. I then manually edited the .h file already present in MinimOSD... Of course the problem lies there! 

    Right now I cannot try this because my FTDI-adapter is missing. (1.5 year old son) :)

  • Hi Gabor,

     

    I'm really stumped, I hope you can help. I'm having an issue: when the system becomes powered up all I see is video from the camera, but no overlay. If I unplug the camera, the overlay appears with a grey background - if I plug the camera back in, the overlay stays, but it flickers at a high rate. 

     

    I took a video that follows the above destription (power on & see vid only, unplug camera to reveal osd, replug camera to show overlay flickering) - it's hard to notice the flickering through the video for some reason, but I assure you it flickers and is quite painful to look at lol.

     

    3DR minimosd 1.1 (with 5v bridge is soldered on both sides)

    MinimOSD-Extra_Plane_Pre-release_2.4_r719.hex 

    CT Tool for MinimOSD Extra 2.3.2.0 Pre Release r713

    650TVL Sony Super HAD II CCD camera

     

    I've tried going down in firmware, re-update charset, going to firmware 712, resetting to defaults, powering the osd with independant (from APM) 5v. Still same behavior - really would appreciate any help. 

     

    Best,
    Raph

    • I having the exact same problem but it does not flicker. When I power up I only get the live video feed with no OSD. If I unplug my camera the osd display shows up and then I can plug the camera back in and get the osd to overlay my live video feed. Has anyone found a reason for this, from Searching online it appears to be a common problem. I'm assuming my case it's operator error. Lol
      • I crashed my copter some time ago. And now that i have rebuilt it i notice the same thing.

        I just unplug and reinsert the video in/out on the osd, and the osd comes on in the video again.

        Didnt have to before

        Bjoern

        • anyone else have any insight on this? my minimosd is brand new and has this problem :\

          • after some testing, looks like the minimosd does not like the resolution of the 650TVL Sony Super HAD II CCD camera. I tried another, with lower res and it works fine.

            is there anything I can do? or is the fix not to use this camera? :\

  • I have a new issue that I'm sure was there the first time I actioned the MOSD and that is, my altitude is showing different (higher) than the telemetry altitude. I have every reason to believe the telem is correct. Any ideas what's causing this? I thought the MOSD was getting same info as telem downlink?

    Thanks,

    Steven

  • @Thomas, thanks. My situation is that I am getting temp readings that look like they are in degrees C even though I have the MOSD set to Imperial.

    Yes, I fully expect the stationary temps to be from 90 to 105 degrees F. But I'm getting more like 33! So, I'm thinking that somehow the MOSD is still in C.

    I'm also aware the temp sensor is ancillary to the baro unit.

    Thanks,

    Steven

  • Hello,

    I'm getting there. Thanks to those who have helped.

    I could swear I once saw a FW that would allow the MOSD to read the "bad packets" info from the TSLRS. I can't find it anywhere. Can someone provide a link or just tell me it was in my dreams. :-)

  • Thank you. I have the OSD set for Imperial units but here is the issue I did not explain thoroughly. When I see the real time temp on the OSD in a room that is roughly 73F, I get a reading of 28. Which to me is probably C due to localized heating from the APM electronics.

    There is a feature in MP that allows you to do a pre-flight cal. I let my plane sit for about 4 minutes to get a good HDOP. During that time, the altitude will change up to 10ft from the boot-up alt. I use the recal function just before I fly to get the best accuracy.

    Thanks,

    Steven

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
yesterday
DIY Drones via Twitter
Thursday
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
Thursday
DIY Robocars via Twitter
Thursday
David Hori liked Isabella Domi's profile
Wednesday
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Monday
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Monday
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Monday
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
DIY Robocars via Twitter
An interesting line-following simulator to use with with your robocars: https://github.com/ron-grant/LFS
Dec 23, 2020
DIY Robocars via Twitter
Dec 23, 2020
DIY Robocars via Twitter
An improved version of the @IntelAIResearch OpenBot: https://diyrobocars.com/2020/12/14/an-improved-version-of-the-intel-openbot/
Dec 14, 2020
DIY Drones via Twitter
An improved version of the Intel OpenBot https://ift.tt/2KkHT8Q
Dec 14, 2020
DIY Robocars via Twitter
Dec 10, 2020
More…