Adding extra functions to MinimOSD

I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Hi I have clicked the enable telem in MP button but to no avail. I have:
        APM >> Telemetry
        5v >> 5v
        gnd >> gnd
        TX >> RX
        RX >> TX

        and

        APM >> OSD
        5v >> 5v
        gnd >> gnd
        TX >> RX

        Telemetry works all the time
        OSD only works consistantly when telemetry is unplugged
        It will sometimes work for a few seconds and then seems to stop updating
        Or it will go throughthe boot up screen and then just display video without the text overlay.

        Hope im pointing you guys in the right direction

        Regards

        Rob

  • hey, have anyone come across the following minimosd behavior:

    works fine for 10-15 power cycles, than all of a sudden you see garbage characters all over the free from OSD info screen. Places where OSD info is supposed to be shown are displaying correct OSD characters like horizon, altitude, GPS and so on. 

    When this happen I have to re-flash both firmware and char set in order for the minimosd to work again. Have tried 2 different OSDs: witespy with KV team mode and a crius one.  flashed with minimosd extra 2.4r726 and minimosd_extra2.4 mcm char set. 

    Also, I have 2 cam setup a sony 700tvl pilot and gopro routed to switch -> minimosd -> vtx. very often OSD info disappears altogether from the pilot cam view, while at the same time gopro feed has correct OSD info. not sure if these 2 issue are related. This happens with both minimOsd boards as well as 2 different video switches. 

    • Yep, happened to me. It looked like my entire screen was composed of repeating "crystals" except for the OSD text, which was clear. I assumed it was just a bad Minim, and replaced it. Then, after a couple of months the replacement did the same thing. Now that can't be a coincidence. So on a hunch, I reflashed everything on the Minim and it was perfectly clear again. I'm not sure which copter version it was, but one of the 700+ series betas. I now have the 800 on it and so far so good.

      • thx Tom, please advise where you got the 800 version? 

    • I haven't seen this but I have seen plenty of weird stuff. I found that going back to the last STABLE FW and uploading the LATEST character set and THEN uploading the LATEST FW gets things as good as they get. I believe R800 is the latest "package".

      • There is a charset uploading firmware in the R800 package to support this.  You can load that, upload the firmware, then re-upload your vehicle-specific code.

  • Hi everyone 

    Ive been racking my brain, read wikis and watched all the you tube videos I can find and asked in FB group.

    I have an apm2.6 from witespy, a minim osd from eBay/neweer and also an osd from witesty ( which I cant connect to, but thats for another day). I also have a mavlink radio which works fine.

    I intend to use both so I made a splitter cable. I have checked the conections 100 times.

    I have 5v to 5v, gnd to gnd, and TX to Rx from apm to mavlink radIO and osd, Rx from apm to TX on radio. Again I have checked the conections even verified on back of board out of the case. I would stake my left big toe on it!

    The osd board seems to be successfully configured through the config tool GUI. On my video monitor I get a waiting for mavlik heartbeat message on the display.

    I have noticed....

    My DIY cable works still with my radio

    When I have mavlink radio connected I lose my flashing red led for TX the moment I connect osd.

    If I feed only 5v and gnd to osd radio still indicates heartbeats, it's when I connect the signal wire to Rx on osd that I lose the red led tx indicator. And my connection to mission planner if I am connected.

    Connected to mission planner or not makes no difference to my problem.

    Connecting signal to TX produces exact same result.

    Feeding 12 v to the video side makes no difference.

    I have also changed the parameters in mission planner according to thhe wiki here.

    I have tried eveverything I can think of and feel like Clark Griswold missing some simple switch!

    Please please help

    • Some have found that this message appears when trying to power the system from the USB cable.

      If that is the case switch to battery power like you are about to fly. Remove the propeller to be safe. 

      • Tried that too

        • When flashed with minimosd 3702773898?profile=originalextra-copter mavlink stays active but all I get is a splash screen from osd on vid monitor.

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
yesterday
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Thursday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…