Advice needed, just setting up Bix3 with Pixhawk, Trim issues and RTL height?

Hi,  I am just trying to setup Bix3 to run on ArduPlane 3.4  Pixhawk.  I have flown RC planes manually including the Bix3, although I am a beginner level.

I have experience using Arducopter on my RCexplorer Tricopter.

Looking for help on a few issues.

- Setting the Elevator Trim.  I have tried using Auto_Trim and setting the values manually but the values although saved seem to be ignored.      (Rudder Trim seems to be working as well as Flap Trims).

I read about a bug involving this subject on GitHub where I learned that MIN / MAX and TRIM are ignored in manual mode, as the values are taken direct from the TX.

Can I ask, perhaps I misunderstand, but how does this make sense?  if I set a trim on Pixhawk for FBWA, then have a trim set on my tx for manual mode, when I switch to FBWA , that TX trim will be added to the Pixhawk trim producing an error, no?    meaning I will need to alter trims on tx every time I switch mode, I realise some TX allow altering trims for different flight modes but that wouldn't help in a failsafe situation where the Pixhawk had a different mode to my tx.

- With regard to the previous question about Trim, I found a parameter called TRIM_RC_AT_START   can I ask what that is and how to use it, maybe its contributing to my Trim problem, but I haven't been able to find documentation on it so far..

- Does anyone know what the correct level reference line is for Bix3. I have pixhawk installed nicely on the shelf below the wings but its idea of level to me seems about 5 (or a little more) degrees out, but I am not an expert so I wanted advice before I alter the AHRS Trim Pitch,

- I am concerned about the RTL height.

I intend to fly FPV medium distance, over a farm.  At the moment I use APM Arducopter,  I was under the impression that Pixhawk was move advanced.

But in Arducopter, I can set RTL ALT, then loiter Alt after it RTL where I can then take visual control over it to land if necessary.

In Arduplane the RTL Alt is default to 100 meters.. and as far as I understand it loiters at the same alt once its got back home. I perhaps don't need RTL of 100 meters, but I do need good height to make sure I avoid obstacles on varying height terrain.

How do people recover a plane manually that is loitering at 100meters?  surely that's too high to control by line of sight especially if the colour of the sky was not suited to the plane.

I would like to be able to set the Loiter Alt after RTL to much lower.   Yes I know if my FPV is working I can bring it down using that, I am taking about control from sight from the ground.

Originally I thought it would be fine to use Terrain following to RTL much lower, but apparently its not recommended to use Terrain following below 60 meters.

- Data logging

At the moment I am not getting any data logs stored on the Pixhawk, I am getting tlogs from the Radio link.

I wasn't worried initially as my Arducopter also only started the data logs after being armed and some throttle action..

But I have been ground testing with the Bix3 pixhawk quite a lot in the last week and still no data logs, I'm not sure if there is a problem if I just haven't done enough to initiate them yet.

Does anyone know when a data log should start in Arduplane, and how I can find out if there is an error starting a log.

(I did tried setting the Armed checks to look for problem logging and it passed)

thanks for any comments

Dave

Views: 512

Reply to This

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service