Hi,

After I did a AutoTune my drone became too responsive.

Before AutoTune flying was way more pleasant.

To rollback these settings do I have to change the PIDs to it's defauld settings?

This is my setup:

Pixhawk with Hexa Arducopter 3.2-rc14

Mission planner 1.3.15.2 (Beta)

Below the screenschots of the PIDs before and after AutoTune:

3691164720?profile=original

3691164780?profile=original

i'm not familiar with these settings and not certain what to change.

any advice is welcome!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • There is the RC feel parameter you can change too.  Its in the tuning parameters I think, and maybe basic?  I cannot remember exactly where it is.  One way makes the response crisper and the other slower.  And by default I think it is set to full crisp response.  It works like expo I think.  Don't use expo in your transmitter to change the feel.  The APM does better with full inputs and letting the computer do the expo or feel changes.

      • Ok, so here are the parameters you want to play with. I do not know why these seem to default to zero on 3.2.  During the development phase for 3.2, we used these.  They do not show up on either the Basic or Advanced parameters pages, but only the Full Parameters list, but they have absolutely no information attached to them.  I'm looking into why this is.

        In the mean time, this is where you see them:

        3702677906?profile=original

        Try setting ATC_ACCEL_RP_MAX to 72000, and ATC_ACCEL_Y_MAX to 54000.  Then set ATC_RATE_FF_ENAB to 1. 

        This should really make the whole thing feel much softer.  This equates to 720 deg/s/s acceleration rate in roll and pitch, and 540 for yaw.  It should feel much softer, but still controllable.  You can try changing them around a bit.  Both those numbers are probably the upper limits of what you might use for a multirotor.  Lower bounds are something like 54000 for R/P and 36000 for Yaw, but that's not cast in stone.  A really large multirotor might use down to 36000 for R/P, but now this will start to get very soft and unresponsive, you wouldn't want to fly like that in tight spaces for sure.

        Helicopters use numbers like 144000 for a small sporty machine flying acro, and I use about 72000 for my camera ship.

        • Hi, my 450 size quad also became over responsive after doing auto tune. So ATC_ACCEL_RP_MAX, ATC_ACCEL_Y_MAX params should be set before performing auto tune?

          • No, it makes no difference for autotune, as autotune bypasses this function when it runs.  The ATC_ACCEL function really only works on the pilot's stick inputs in Stab and Acro.  It does not function on Auto mode controls from the autopilot, or Autotune.

        • Thanks Rob i am keen to give this a try

          David Ardis

        • most excellent.....Thx

      • The RC-Feel is not like Expo, it is basically a low-pass-filter on the stick inputs.  Expo curves the inputs so they are softer around the middle, but RC_Feel slows down any input changes.

        You should also have a look at the Accel Damping parameters.  These can also really soften up the feel of the machine, while still allowing tight PID settings to allow the aircraft to be stable in winds.

        I'm not sure if they are in the basic parameters, but you can see them in the Full Parameter list.

        • So rc feel gives a linear input with a delayed response from the copter?

          • That is correct.  It's just an LPF.

            The ATC_ACCEL parameters use a physical limit to the rate of change of the target angle.

  • I had similar result in my cuad and I change stabilize roll and pitch to 7 and flies smoother

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
yesterday
More…