Hi All,

I recently upgraded to an air speed sensor for a wing wing z84.  Plane flies create in FBWA and AUTO but it does not seem to control air speed very well.  Cruise speed is 10m/s but its flying at least 20m/s. Altitude control seems fine. Wind was slight. I did the preflight calibration was reading 1-2m/s airspeed on ground.

How do I tune the TECS control for better control of the airspeed of the plane.  I think it could be the TECS_SPDWEIGHT parameter but im not sure exactly how to change it. 25% throttle gets about 10m/s but in AUTO its sitting up at around 45-50% and hence why it is so fast.  I've tuned FBWA so the max and min climb/dec work well with max/min pitch.

Could someone shed some light on tuning of this and how to reduce the airspeed? Even a simple starting point will help me on how to reduce the air speed in AUTO.

Thank you.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • How long did you run airspeed autocal mode in flight?  What is your airspeed calibration value?

    • Thank for your reply Scott. I ran it for about 5-6 minutes.  The calibration value is 2.26.  The air speed is quite accurate i believe.

      I managed to lower the air speed by setting the max air speed parameter to lower values.  Basically the plane was always flying at max air speed regardless of any tuning or changing cruise speed or throttle trim.

      [SOLVED] I found the problem this morning.  After a lot of checking, the MIN_GNDSPD_CM parameter was set to 9000 so 90m/s instead of 900.  So the plane was always flying at max air speed to try achieve min ground speed.  

      • Ah.  Great!  That would do it. :)

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21