Airplane/APM flies RTL regardless of mode setting in AUTO or RTL

Guys:  

As many of you have seen from my postings I am struggling to get my aircraft to fly in auto mode.  Many of you have helped me chase down suspected problems with compass and various other suspected problems. I have yet to get the aircraft / APM to actually fly successfully in automatic.  It has flown well inManual,  FBW-A, Loiter, RTL, Circle etc.  

Today I discovered a problem with my APM / Mission controller that may help us identify the real problem.  I have three modes on the channel that I switch between Manual, RTL and AUTO.  I confirmed on the "Flight Data Screen" of the Mission Planner that when switch the mode switch that the display on the HUD display changes when I changed the switch.  HOWEVER - I learned today that there is no difference in the APM's actions between RTL and AUTO, even though the HUD display changes.  Please see the attached Tlogs and waypoints for verification.  I am sure there is something that I don't have set correctly, but this has been a challenge.  I frankly found this by accident today when I was switching between RTL and AUTO and noticed the airplane continued to circle above the RTL site.

  • I am using APM 2.5
  • Today I upgraded the APM firmware to V.2.7 in the APM, but the same thing happened in V 2.69
  • I am using a Hitec Aurora 9 with an Optma reciver
  • After discovering the fact that the APM did not change even though the mode was changed, I re-calibrated the radio a couple times with no joy.

Below is a narration of the actives today that I sent to a friend who has been trying to help me it may contain a clue:

I learned something very interesting.  I had changed one of the three remote actions to RTL (return to launch).  In addition I still had manual and automatic where it is to fly the way points.    I flew it out manually a ways and switched to RTL.  It came back over the launch site and perfectly held altitude and circled above me 400 feet.  It was so solid that I walked over to the truck and messed with the computer while it was flying!  Then, flew back out a ways and switched it to "automatic".  Instead of heading out  to the way point it turned and headed back toward me.  So a couple times I switched it back to manual and flew it back out but each time it came back to me, holing a nice altitude.  So I just let it go to see where and what it was going to do.  It circled around me and held a perfect altitude and around and around it went - just like the RTL.  So, while it was flying over me I switched it back and forth between automatic and RTL, but it kept circling above me.  I walked back over to the computer to verify that the HUD data on flight data on the mission planner displayed "RTL" when I had the switch in that position and "Auto" when I had the switch in that position.  Sure enough, the switch had no effect.

If any of you can can give me some direction, I would greatly appreciate it.

Bret C

Views: 4039

Attachments:

Reply to This

Replies to This Discussion

Bret, have you verified that the APM actually engages the auto mode when you have the switches in the "auto" position? It may have something to do with the way you set up the interaction between the switches controlling different modes. The way I have my switches set, it is not possible to engage Auto mode while the RTL switch is in the "on" position. Could you have a similar setup on the Aurora 9?

Bret, you may have a problem with loading the mission to APM.  If you switch to Auto and there are no valid navigation commands in the mission in APM, then it will switch to RTL.  Load a mission and then clear the mission in Planner and download it from APM via telemetry to verify it is correctly being saved by APM.

Deon, yes I have verified that the APM switches to MANUAL/RTL/AUTO.  When I move the switch the display on the HUD display changes accordingly.  The TLOG on this posting also shows the switch being moved but the airplane continues in the RTL mode.   To your point, it is not possible on my radio set up to go into RTL and AUTO at the same time because it is a three position switch.

I have the three modes assigned to the three position switch "E", which is assigned to ch5.  When the switch is pulled toward me, it is in manual, middle position it is in RTL and when it is pushed away from the operator it is in AUTO.  The CRAZY thing is that the display on the HUD displays the proper assigned switch position.  Also it may be note worthy to know that I have changed the mid position of the switch several times from CIRCLE, FBWA ect and they all worked great as well as they were properly displayed on the HUD.  After I stumbled upon the fact that the airplane was flying in RTL when it was actually was in AUTO - I re-calibrated the radio thinking that just maybe there was a problem with the calibration but still no joy.  The only thing that I have not done is to reassign AUTO to the mid switch position.  I intend to try this today.  

Also in an attempt to resolve the issue, I changed the EPA (end point adjustment) of channel 5 to 140% and re-calibrated the radio.  However that test flight was blotched by dumb thumbs on take off and I stripped the servo gears.  I re-installed new servos this morning and will be headed back to the airport soon, so any suggestions will be very welcome. 

Doug:  I really appreciate your input.  I have suspected all along that the problem is something simple like you described.  I did just what you described a few times yesterday.  However I may be missing something very basic as to what is a good mission plan.  This morning I uploaded the mission to the APM, cleared the way points (flight plan) from the Mission Planner screen then READ the way points from the APM.  Those way points are attached to this reply.  If you are able to look at them to see if there is any problem, I sure would appreciate it.  

With all this said, is there something that makes a bad flight plan?  Might there be something checked or wrong that is known to cause problems?

Thank you Doug!

Bret C

Attachments:

Doug;  Another question about your point that "the APM will switch to RTL if there is not valid navigation commands".   If this occurs will the display in the HUD display AUTO or should it switch to display RTL?  The reason I ask, when I tried to get my Hitec system to function with the Ardrupilot "FAIL SAFE"  feature where if the throttle signal drops below a threshold that the APM will automatically switch to FAIL SAFE.  In observing this, the HUD display in the Mission Planner does switch to FAIL SAFE when it is activated.  So, with this in mind- does a faulty mission (way points) do the same?  Shouldn't it change the display to RTL as well?  This has not happened to me as while the aircraft continued in the RTL holding pattern I observed the flight data on the Mission Planner to display the correct mode.

So, although I would like to think that the problem may be a faulty mission, it does not display the RTL mode in the HUD display when AUTO is activated.  It just displays AUTO.

Thanks

Bret C

Bret,

Have you thought about trying the flight simulator software and using HIL to test out different mission commands, mode settings, failsafes etc. and generally play about without endangering your craft, you can download the free demo version of X-plane to use if you don't have the full version.

I have it set up with my APM1 and X-plane9 and am able to fly missions, set up photogrids and trigger the camera at waypoints all in the comfort of my den.

Hi Bret,

The mission you posted looks OK.  Basically a mission must have at least 1 navigation command (TO, WP, loiter or land).  I prefer to end all missions with an unlimited loiter or a land command.  If you do not then after the last navigation command is executed the mode will switch to RTL.  This is not a failsafe condition and the HUD will definitely not say failsafe.  I beleive but do not recall 100% that it will switch from Auto to RTL on the HUD display.

So you are saying that when you switch into Auto the HUD display shows Auto but the behavior is RTL?  If it shows Auto it should also display the navigation point it is trying to go to.  If it is showing that it is going to point zero then it is RTL because it thinks the mission is over.  Not sure why that is happening to you but you could try changing the current waypoint to waypoint 1 through Planner before switching to Auto.

You don't happen to have your waypoint radius set crazy big, do you?  If you had your WP radius set bigger than the mission area the mission would execute more or less instantaneously because you are inside all the WP radii.

Doug: I am at the airport now so I will be short. My dietary flight to the field was the first time that the aircraft actually followed the way points. I then changed a flight mode and now we are back to all AUTO flights being done as RTL. I will try to replicate what ever I did to make it work. Wow! What a PAIN!

Hi, it has happened to people before that RTL was engaged (or at least the effect of it) while auto was really selected. The last time that happened to me my plane headed straight home but through a hill instead of following the waypoint over it.......

Regards

Soren

Martin:

Thank you for your input.  Yes, I had thought of hooking up a simulator, but did not take the time to do that.  

I just returned from the airport and write an update on this thread.

Thank you for your help Martin.

Bret C

Soren:

Thank you for your input.  Yes there is defiantly a problem with the APM going into RTL.  One of the HUGE problems is to diagnose the problem you just have to fly it because the APM does NOT tell the truth.  It says that it is AUTO mode, but actually it is in RTL.

I believe Doug W in this thread is right.  The problem is that the mission loaded into the APM was flawed. However, I READ the waypoints from the APM, and everything looked ok, but in reality something was wrong.

I will go in to more details in a response to this thread.

Thank you for verifying that there has been a problem before.

Bret C

Guys:

I just returned from the airport conducting several test flights.  

My first test flight was GREAT!  The aircraft flew in MANUAL, FBW-A and AUTO, yes it even flew the way points!  (First time after weeks of attempts) I thought that we had this figured out!  I landed, changed the modes from MANUAL, FBW-A and AUTO to MANUAL, RTL and AUTO.  I wrote the change to the APM and tried it again.  The next flight took me right back to where we started where AUTO was not recognized but the only two modes I could get to work was MANUAL and RTL.  (AUTO functioned as RTL)  In an attempt to recreate my first mission, I turned everything off; transmitter, unplugged the APM/aircraft batteries, turned off the computer etc.  The next flight was just like the second, where AUTO operated as RTL.  So through a series of turning things on and off, uploading the mission again to the aircraft, reading the way points, re writing them etc. I was finally able to get it to fly AUTO mode correctly two more times. But several other flights were flown where AUTO still functioned as RTL in the process.  (BTW - I changed the three modes back to MANUAL, FBW-A and AUTO thinking that this could have been the problem - but this had no effect)

So the fact of the matter is that I am not 100% sure how I was able to periodically get the APM where the AUTO mode was able to function correctly but it had something to do with unplugging the APM/computer and uploading the mission again.

I think Doug W in this thread nailed the problem which is the mission I uploaded had a problem.  Although that may have been the problem (no way of knowing), the bigger problem is the fact that there is no way to know if the mission has a problem when it is uploaded.  To further this problem, while in flight when you switch to AUTO mode and the aircraft comes back to RTL, the HUD display still shows AUTO.  The lack of this basic diagnostic indicator costed me days of research and experimenting.   Although I learned a lot - I sure wish I had all that time back!

On a similar note, after one of the successful AUTO flights today, I landed, pressed "restart mission" on the Flight Data tab of the Mission Planner.  (I am not sure if this is the correct way to restart the mission)  The aircraft started the mission, then headed for a way point on the ground.  I aborted and landed.

So, guys - I appreciate everyones help.  We thought the problems I have been encountering were caused by a bad or incorrectly calibrated compass and various other things.  If others encounter similar problems, where the APM will not follow waypoints and you don't know what it is trying to do - it is probably returning to launch! (RTL)

Based on my experiences, it does not appear that the Ardrupilot will be a good solution for our applications.  We will continue testing with the Adrupilot, but we will also evaluate other systems as well.

If I happen to figure out what sequence of turning on equipment and uploading way points that creates a successful AUTO mode flight, I will post my findings to this thread in an effort to help others in the future.

Bret C

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service