Airspeed Issue

HAs anyone had issues with the airspeed sensor using ArduPilot with the shield?  I have set the proper millivolts in the code but it doesn't seem to work right.  After loading the code and looking at the GCS at a standstill the airspeed is 0....great.  At the slightest breeze (or blow toward the tube) the airspeed jumps up to 200 +/-40.  It's never worked since I've been using the GCS.  This is happening on 3 separate ArduPilot setups so I know it's not the hardware.  Any ideas, thoughts, or experiences with this issue?

Thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hello Sebastian, I see the name Brifly on the above but can't help think I have posted or not quite understand the nature of this site. Whether or not this is my post I can say I have had the same experience with the airspeed readout in the GCS. I will certainly give this a try and see if that display is corrected. Thank you. The real trouble I have with the entire unit, shield, ardupilot and all is a receiver range as I have posted elseware. When used with 2 different receiver/transmitter units the range is only perhaps 50ft at this time as ground tested before the control surfaces go crazy. Obviously I cannot trust my plane to this and have not even attempted using the unit. I even tried contacting Sparkfun but no response. Not surprising since the product is not supported anymore. Was hoping to find a hardware fault and replace an onboard chip or something. I can afford the mega but am stubborn natured and hope to somehow figure out the trouble! No one else having this issue. Thanks again.

  • Hello,

    I know, this post is very old. But here is the answer of the question.

    You have to change the GCS_standard_text.pde. Because airspeed is send in cm/s but the GCS expect it in m/s.

    Change line 180 from "Serial.print(airspeed,DEC);" to "Serial.print(airspeed/100,DEC);"

    Regards

    Sebastian

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
1 hour ago
More…