Hello,

 

Yesterday, I was running 2.0.45 (I think),  loaded previously through mission planner 1.0.76.  My stabalize PIDs were turned well and my jDrones hexa flew nicely (impressively well,  actually,  thanks for the good code!)

 

The only problem was, I could not for the life of me get ALT HOLD to work (it had worked in a previous version of the firmware, with default PIDs  I dont recall which version).  I would reach a hover ~5 feet off the ground,  and flip my control switch into ALT HOLD.  The copter would then tend to either sink slowly until it landed,  or climb into the air.  I spent a few hours adjusting gains but no success.  I read a post about a similar problem,  and the only comment was to upgrade to the new software.

 

Today,  I used the mission planner 1.0.77 to install ArduCopter 2.0.46.  I reconfigured all copter parameters (leveled,  calibrated,  etc) and took it out for a test flight.  As just barely throttled up the copter,  the motors ramped to lift off speed,  and rolled the copter completely over.  Fortunately I was able to kill the power before any major damage was done.  I reset the EEPROM a tried recalibrating all settings and the problem still persists.  Does anyone have any idea  what is going on?  I will try to get a log file up later when I have a minute if that would help.

 

Also,  with Mission Planner 1.0.77 and Arducopter 2.0.46,  there are no P, I, or IMAX values retrieved from the copter and none can be set.  Is this intentional?

 

Also,  on the previous firmware version I was running and with 2.0.46,  in both Mission Planner 1.0.76 and 77,  the battery configuration area,  where it says to enter various battery voltages,  all the boxes are grayed out and do not allow input.  Is this intended?  I have an autopilot current sensor that I am trying to get set up.

 

Should I be compiling the code from scratch and loading it through the Arduino IDE?  Also,  is there some sort of changelog for each version of software that is released,  so I know what sort of changes to expect?

 

Forgive me if any of these problems are obvious, I have searched tested to the extent of my knowledge and not found answers.

 

Thank You

Views: 248

Reply to This

Replies to This Discussion

What were your Rate_Roll_I and Rate_Pitch_I values?

Jason

Yesterday i flew my arducopter hexa V2.4.1 and the same thing happened to me. I barely throttled up the copter,  the motors ramped to lift off speed,  and rolled the copter completely over (3 props got damaged). Any solution to the problem?

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service