Hi,

I had a routine flight for an hour or so with my pixhawk in arduplane 3.5.2. The plane flew well for about fifty minutes or so in auto. After that, I switched to loiter a couple of times. Each time, the altitude dropped immediately on switching to loiter. I then decided to land and switched to FBWA. I started to approach for landing, when suddenly, after a turn, the plane plummetted nose down and crashed.

I was using a RFD900 for telemetry.

Some observations I've made -

  • The mission planner showed an altitude of 17m at the time of the crash.

  • The Nav pitch was always high, about 40 degrees during the auto flight

I tried to attach the logs, but I couldn't because of the size limit, so I have put it in a drive link
https://drive.google.com/file/d/0BzvtRMZaahWwWHk1UW0tNE5Xdlk/view?usp=sharing

Any help would be much appreciated. Thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Amm, do you make the write Compass altitude setting? I mean if you now in the ground, does the telemetry says u r at 0 altitude ?

    Also do you set the Loiter settings ? << altitude and if there another ?

    Hope u fixed it though xD

    Please post if it is fixed.

    Thanks

  • I would like to see the answers to this also.

This reply was deleted.

Activity

xemone liked Max Gilson's profile
Aug 31
nick rymer left a comment on ArduCopter User Group
"I recently switched laptops and now have Windows 10. I installed Mission Planner on my laptop and plugged a mRo SiK Telemetry Radio into the USB port. The radio is not recognized on the com ports but is instead on the "Other Devices" tab in Device…"
Aug 20
More…